2

I have two WordPress websites on shared hosting under the same account, i.e. different folders on the same server. Permalinks work on one site but not on the other site. On the broken site I receive an apache server 404 error message when accessing pages other than the home page.

This is what I have tried so far to fix the broken permalinks:

  • Re-saved permalinks.

  • Deleted .htaccess file - then saved permalinks again. The .htaccess file is generated successfully on the server with this content:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress 
    
  • Switched theme to Twenty Seventeen theme.

  • De-activated all plugins.

I don't have access to the server to check the apache2.conf file for:

    AllowOverride All

But am I right in thinking that this should be set correctly because the permalinks are working correctly for one site?

Any other suggestions for what I could try / test to get this working?

Thanks very much!

  • are the sites in a different subdomains or on the same domain? – madalinivascu Apr 11 '17 at 6:25
  • They are on different domains. – junkrig Apr 11 '17 at 6:36
  • Do you get an INSTANT 404 error? Because WordPress takes a bit to load, and if you get a 404 error instantly it means that the server returned a 404 error even before sending the request to WordPress. In this case you probably would want to contact your hosting for support. – Jack Johansson Apr 11 '17 at 6:39
  • Yes, it was an instant 404 error... – junkrig Apr 11 '17 at 6:42
2

It turns out it was a server issue after all.

Adding junk text to the .htaccess file should produce an error but it didn't, indicating the .htaccess file wasn't being read at all - https://docs.bolt.cm/3.4/howto/making-sure-htaccess-works

I had another look on the hosting console and there was an option to "Sync" the .htaccess file. This fixed it up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.