0

Before I begin, I do not have WordPress having permissions to update the .htaccess file. That's not what this is about. I'm full aware of that.

My problem is WP generates the same file every time for me to copy to my .htaccess file. With default permissions:

("Post Name" setting:)

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpress/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpress/index.php [L]
</IfModule>

RewriteEngine On RewriteBase /wordpress/ RewriteRule ^index.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /wordpress/index.php [L]

("Numeric" setting:)

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpress/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpress/index.php [L]
</IfModule>

Same exact thing. That setup works perfectly when the "default" setting is used, but it's not working now. I've tried copying it before and after I save the changes, but it's still the same.

Why isn't this working? I believe this is the right file setup (I access it with xxx.xxx.xxx.xxx/wordpress/)...

/var/www/html/wordpress$ sudo nano .htaccess

0

Pretty Permalink parsing happens internally within WordPress, any permalink setting other than default uses the same .htaccess rules, because all variants simply direct any request which is not a physical directory or file to WordPress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.