0

WordPress 5.6, WooCommerce version 4.9.2, PHP Version 7.4.14

Dear,

I am facing a problem with permalinks. When having 'post name' selected, permalinks work for all pages expect 'blog'. In this case, no posts appear on the blog page. Only the page title. When having 'plain' permalinks selected, everything works like a charm.

I have troubleshooted by disabling plugins, using other themes, checking the .htaccess file on correct content/permissions, home/blog page correctly set in 'reading', but without success. I contacted my hosting company to check if mod_rewrite module is enabled and web directory override rule is set to AllowOverride All (waiting for their reply), but believe the problem is not on server level as other permalinks (e.g about & contact-us pages) work fine.

Thank you very much in advance for your help.

Kind regards, Quinten

EDIT: PROBLEM SOLVED

2
  • Quinten, would you like to answer your own question and explain how you solved the issue so other people who come across this can try the same solution on their sites? – Tony Djukic Jan 29 at 15:23
  • 1
    Good idea. Thanks Tony – Quinten Jan 30 at 16:21
0

The error was generated by the Elementor plugin. Setting 'Landing Pages' on Inactive in the Experiments menu in the Elementor settings did the job.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.