0

Right, this has me stumped.

I cannot get the pretty permalinks to work. They go to 404.

The permalinks are updating, I can see the URL change to each setting as I save them by going to a post, but only the default "p=ID" works.

  • Wordpress is installed under /var/www/html/
  • .htaccess is being created and updated whenever I update the permalinks
  • Owners and Permissions are set to www-data:www-pub and 755/644 (dir/file)
  • AllowOverride All is set in the [my-site].conf file
  • mod_rewrite is enabled
  • apache2 has been restarted (several times).

Any ideas which I've not tried?

2

... and as per usual, I figure it out as soon as I post the question -.-

Using this answer, I changed apache2.conf under /etc/apache2/.

There is a section towards the bottom talking about the security model. The section Directory /var/www/ needs to be changed from AllowOverride None to AllowOverride All.

I restarted apache and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.