0

I'm working locally on Ubuntu 16.04 LTS machine, with apache2 server. I started developing the site on Windows 10 before moving to Ubuntu.

I now have this problem:

When I set Permalinks to "Post name" all pages, except the front page, are not found by the server.

By the way, when moving to Ubuntu I also changed the site url. However, I did similar changes when moving the site to a remote server with no problem at all.

My .htaccess is writable looks like this:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /nuritzurgil.co.il/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /nuritzurgil.co.il/index.php [L]
</IfModule>
1

For permalinks to work, you need mod_rewrite module enabled on Apache server. Check your Apache configuration and make sure mod_rewrite is installed and enabled.

Here is the easy to follow tutorial for Ubuntu 16.04 to enable Rewrite module: How To Rewrite URLs with mod_rewrite for Apache on Ubuntu 16.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.