3

Yes. Then it works. Add a new post and see if it changes. You can submit your sitemap to search engines but they will eventually pick it up regardless. Just give it time to see results -- it's not instant. Use Google Console https://www.google.com/webmasters/tools/sitemap-list to make sure it's getting picked up.


3

Go to Admin > Settings > Permalinks and click save without altering anything "Sometimes resetting the permalink structure will quickly solve a 404 error from a recent change to your installation." See http://kb.yoast.com/article/77-my-sitemap-index-is-giving-a-404-error-what-should-i-do for further details


2

In order to be indexed by google news you need a unique permalink structure containing a unique number. You seem to have a permalink structure of %postname% that doesn't contain a number. You could change your permalinks for example to %post_id%/%postname% or %post_id%-%postname% in order to comply with google news requirements.


2

You can always delete the .htaccess for each root directory, then visit each domain.com/wp-login.php then visit: Dashboard -> Settings -> Permalinks & save changes. (Automatically generates a fresh .htaccess) OR login to phpmyadmin for each domain, check out the database... options table... verify the "siteurl", and "home" columns. make sure they ...


2

Hate to self promote BUT ;) My WordPress SEO plugin actually fixes this by not generating a static file at all. It works in all circumstances.


1

Okay, after digging into various areas, I noticed I have a security plugin that is blocking these changes. Problem solved by whitelisting, :) in case anyone else has this issue, check your security settings.


1

First of all, you can use Stack Overflow in Russian, there is a WordPress tag. Concerning your question, it seems everything is OK with your sitemap. Yoast SEO generates index sitemap mentioned in your question and several sitemaps for pages, posts, taxonomies, products in WooCommerce etc. You can check this sitemap in Google Search Console, accessible via ...


1

Let's assume your plugin is writing to the /usr/share/wordpress/sitemap_index.xml filesystem location, but you want it can be accessed through http://www.website.com/sitemap_index.xml as if the xml file were stored in /var/www/html/sitemap_index.xml. You can use the alias directive then, available in mainstream webservers Apache and NginX: For an alias in ...


1

Each one creates an HTML sitemap of the Magento store without any reference to blog or posts whatsoever. I think you are misunderstanding what is happening here. XML plugins for WP would not go and create arbitrary HTML sitemap. That's just not what they are meant to do. Since you have two different things in play here I tried to figure out what is what, ...


1

Google does not index anchor tags, only URLs. (Note that by anchor tags, I assume you mean a URL like site.com/page.html#anchor) The solution is to create a separate, static URL that displays the same content as what you would get with the anchor tag - for instance site.com/page-anchor.html. Then you can just create a page with links to all these new URLs,...


1

Pings are a mechanism for a fast update. For example if you are using a external feed service you want it to update as fast as possible when new post is up. Search engines do not care about it in this way. Pinging search engine won't typically mean it will bother to index page immediately (if at all). Site maps are a mechanism for methodical update. They ...


1

I think the better solution would be to create a custom page template for showing content to logged in users only and use that template to all password protected pages. Then you can create a single user for teachers/staff members so they can log in and view content. This way they will only have to login once on website to view several pages. Even they don't ...


1

Possible mistake: depends on what you mean by 'page'. Search engines would count archives pages as pages, whereas WordPress will only count post-type page, not archives nor posts.


1

I had the same problem. The # was caused by the plugin "Page Links To" for me. This is a plugin that makes certain top level navigation link so that nothing happens when you click it and you have to choose a subcategory. With Yoast SEO, you need to edit each page using # as a redirect under Advanced settings to "Never Include" in Sitemap. I also chose No ...


1

Okay, I ended up using the Google XML Sitemap plugin. You can input the post id's of the pages you want excluded from the sitemap. I excluded the pages with null links and now Google accepts the sitemap.


Only top voted, non community-wiki answers of a minimum length are eligible