3

If you are using an SEO plugin such as Yoast, it automatically adds all Custom Post Types (and Taxonomies) to the sitemap that is used by Google & other search engines. You will need to explicitly exclude them from the sitemap e.g in Yoast, this is under the "Post Types"/"Taxomonies" tab in the "XML Sitemaps" settings page. Also don't forget to remove ...


3

How about something like this on your functions.php: add_action('wp_head', 'no_robots_on_uncategorized_posts'); function no_robots_on_uncategorized_posts() { if(in_category('uncategorized')) { wp_no_robots(); } } This will output the following line of code on the header of your 'uncategorized' posts: <meta name='robots' content='...


2

Google doesn't always show the meta descriptions and title's that you set. This is taken directly from Google's Search Console help pages. Google's generation of page titles and descriptions (or "snippets") is completely automated and takes into account both the content of a page as well as references to it that appear on the web. The goal of the snippet ...


2

It's called Author Rich Snippets. Your link needs to look like <link href="https://plus.google.com/115911773396772351667?rel=author"/>Your Name</a> The Simple Way To Set Up Author Rich Snippets There are a few things you need in order to step up Author Rich Snippets: A public Google+ profile. Make sure to upload a decent looking profile ...


2

There is a way to hide a post type by default from Yoast. However your milage may vary depending on what you are doing with your post type. If you are using it on the front end directly then this won't work for you. In my case I was pulling the content via shortcodes. So the 'public' argument when registering your post type enables/disables a few arguments ...


2

The basic problem for a script solution is: rel_canonical does not offer any useful filter. So we have to replace that function: remove_action( 'wp_head', 'rel_canonical' ); add_action( 'wp_head', 't5_canonical_subpages' ); The next problem: $GLOBALS['numpages'] is empty before setup_postdata(). We could call that function already here, but it might have ...


2

I know - I hate the fact that Google indexes the site code, and then floods my logs with 404s for old files. You can add something like this to your robots.txt file: User-agent: * Disallow: /wp-content/plugins/ Disallow: /wp-content/themes/ You could probably just have Disallow: /wp-content/ but that would also stop your images in the uploads folder from ...


1

When have you done the translation? Google chaches the information of your site, means a chance of your site take time till google-crawler was there again and noticed the change and write a new chache...so changes can take till some weeks till google shows the new version...


1

Also, don't develop on the stage server. You'll face a lot of problems in the future doing so. Develop on the local computer.


1

The cause is automatic indexes on folders on your server. For example https://www.yoursite.com/wp-includes/ shows an index of all the files in the folder. The solution is to turn off indexes add this to .htaccess Options -Indexes If you can’t do this then tell your host to disable indexes


1

Google also pulls information from the PDF file itself. To truly fix the files, you'll need Acrobat Pro. You can then edit the embedded title, and you then delete the original and upload a new one. If these PDFs are associated with specific Posts or Pages, it's safest to go to that individual Post or Page editing screen, delete the link from the content and ...


1

This is actually the place for the webmasters.stackexchange.com. But to answer your questions: Google trying to show the most relevant results based on what the search query is. This also includes the meta description. Google may choose to show another content on your page which is different than your meta description tag. From moz.com Google's attempts ...


1

Without getting into the structured data itself, it is important to remember that the actual url on which wordpress will run the search has to be the home page. If you are using "pretty permalinks" wordpress will probably try to parse the url as content, not as search for almost anything that is not the home page. So you target URL should probably be example....


1

You should set rel alternate hreflangs on both sites - <link rel="alternate" href="http://example.com.au" hreflang="en-au" />on example.com and <link rel="alternate" href="http://example.com" hreflang="en-us" /> on example.com.au then you sholud set targeting site content to a specific ...


1

You could check for a log-in cookie in your .htaccess, but that can be spoofed: RewriteCond %{HTTP_COOKIE} ! wordpress_logged_in_.+= [NC] RewriteRule \.pdf$ - [F,L]


1

Basically permalinks is easy to setup then there are seo optimization tools are paid and non paid available. Some of common use plugin are All in one SEO yoast seo XML Sitemap Generator for WordPress W3catch or Wp rocket Meta slider (for SEO optimize image slider) And finally , its relatively easy to find more plugin and themes as needed.


1

WordPress is SEO friendly as anyone can implement things that are important for SEO. For this you need to first understand SEO rules and its technique that is how you would be able to make use of WordPress in better way. It is simple, easy and quick to use


1

WordPress doesn't give you tips for SEO, it just makes it easier to deal with SEO settings. You don't need to code every meta fiels, because you have it provided. Similarly, you get permalinks option and can choose the looks and structure of your URLs. But if you know nothing about SEO rules and techniques, this won;t help you. With SEO, it is you who's the ...


1

You could try the Google CSE plugin. I've tried both the plugins you mentioned above, but I couldn't get them to work in the way I wanted, so I settled with the Google CSE plugin, and I'm rather happy with how it works. It actually serves the results from your Google Custom Search Engine via the WordPress search listing, which means there is no need to ...


1

The WP in their URLs is not related to WordPress, it’s just a shorthand for WebPage. These types all have the type WebPageElement as parent. In my opinion, using WebPageElement or one of its sub-types (like WPHeader etc.) is pointless for general web pages (there are some special cases and non-HTML contexts where it might make sense to use these types). It ...


1

This is not something that WordPress core adds, it is something that themes add, and to know why, you will have to ask the authors.


1

It can be extended but not easily as the search searches just in the DB and shortcodes usually do some calculations in order to produce the final HTML. To use the Google Custom Search you just need to get the code and add it to the site as a widget or part of the theme's code.


1

I'm sure you've googled 'khabarnaak' - it's a Pakistani talk show. It's more likely to be an automated scraper trying to find content rather than an attack. The request does not look like it has been crafted for a Wordpress site. Two ways to stop it are: Block the IPs making the request. Add 'Deny from XX.XX.XX.XX' to your htaccess file, replacing XX.XX....


1

You may have disabled indexing, ensure you have 'Discourage search engines from indexing this site' unchecked under Settings -> Reading


1

If you have an actual robots.txt file in the root of your site then WP/plugins will be unable to override it. Its related functionality works with "virtual" file, when actual file doesn't exist. Otherwise it might be plugin conflict, try one related plugin at a time.


1

Adding feed to the end of URLs is not an error, nor should it result in 404's. WordPress supports sending most any page's data as a feed, and Google crawls them for URLs and other information along these lines.


1

In Google Site search, you can set up Refinements ( Edit Search engine - > Search Features -> Refinements tab. You can also set synonyms and promotions (so that particular pages will always appear at the top of specific search results pages). The Google content is based on spidering though, so it won't understand back-end concepts such as 'tags' or '...


1

As noted above, when I tried that code I ended up on a server level 404 page. If this is meant to be a standard WordPress search ( ia m not sure if it is) you need to be using name="s" and not name="q". WordPress uses the s GET variable for a search. The following submits to whatever page I specify in my install: <form method="get" id="searchform" ...


1

This is a bit of a guess but there is a setting in the backend that will discourage indexing. Make sure that is not checked.


Only top voted, non community-wiki answers of a minimum length are eligible