1

I recently migrated a WordPress install from a shared managed host (cPanel) to a VPS. I first installed WordPress on the new server, then installed Migrate Guru and then migrated the install over to the new server.

Everything worked really well, there is just one issue. When I look at the "Site Health" tab I get the following "Critical Issue":

"A plugin has prevented updates by disabling wp_version_check()."

This is the only critical issue the WordPress install shows and it wasn't there before the migration.

What I tried so far to fix it without success:

  1. Cleared the install and repeat the migration
  2. Deactivated all plugins
  3. Deleted all plugins
  4. Switched to a basic twenty theme
  5. Installed "Health Check & Troubleshooting" and activated the troubleshooting feature

None of this helped, it still shows them same error. My new host looked into it and said that they've cross checked the possible logs and syntax of the web application in regards with the error shown in the site health tab but weren't able to find any error based on the event.

EDIT: I added the plugin WP Control to see if I can run wp_version_check() manually and I couldn't. Other cron events like wp_update_plugins also "Failed to execute" when I tried running them manually.

I added the following line to the wp-config file: define('ALTERNATE_WP_CRON', true)

Now running those cron events manually worked. However, the initial site health issue still persists.

Next I removed the above line from the wp-config file and now the critical site health issue is gone, but two new critical site health issues show:

"The REST API encountered an error"

and

"Your site could not complete a loopback request"

Both show the following error in the description:

"Error: cURL error 28: Operation timed out after 10000 milliseconds... (http_request_failed)"

EDIT: Now, without changing anything the two new Site Health issues disappear and the old one is back: "A plugin has prevented updates by disabling wp_version_check()."

  • You can atleast mention list of plugins installed. – Gangesh Apr 24 at 2:51
  • @Gangesh, the plugins were deleted and the issue persisted, so it's not really a difference maker. So, your VPS, the WordPress install on it... ...did you manually configure the server to manage WP and install all the PHP modules needed, set the permissions and groups or is it like an AWS VPS where you launch a new WP instance with Bitnami or some other vendor? – Tony Djukic Apr 24 at 15:56
  • I ask this because on some hosts, like FlyWheel as an example, they hold back WP updates until they do internal security testing, and once they've double checked everything, release the update so that you can manually do it, or it gets auto-updated after a week or two of them clearing it. The wp_version_check() is disabled by them. – Tony Djukic Apr 24 at 15:58
  • @TonyDjukic I am using Runcloud and a one-click install of WP. With the plugin I used for the transfer (Migrate Guru), you first have to install a fresh WP on the new server and then they migrate your whole site to the new server via FTP. I have other installs on Runcloud that don't have this issue, however they were built freshly and not migrated. Runcould support seems to have no idea where this issue comes from so I suspect it's an issue that comes from my old host (shared server with a managed cPanel). – Th526 Apr 24 at 16:32
  • I read through their documentation and didn't see anything about them managing WP Updates. Did you check for a mu-plugins directory and see if there's maybe something in there? Additionally, check the wp-config.php file for this line: define(‘WP_AUTO_UPDATE_CORE’, false);. That could also be the culprit. – Tony Djukic Apr 24 at 17:11
1

This might not be the issue, but I would install the All In One WP Security & Firewall plugin by "Tips and Tricks HQ" and use that plugin the check your file and directory permissions. Often times file permissions or also file ownership gets messed up in migrations. Seeing as you have deleted all plugins and are running the stock twenty something theme, it might be giving you a false error. Also, you could try reinstalling WP Core. That might help too. Just a thought.

| improve this answer | |
  • I tried this and unfortunately the issue persists. I will add some info to my original post. – Th526 Apr 24 at 14:54
0

Please check error.log from your server if there is something like this:

AH01630: client denied by server configuration: /var/page/wp-admin/site-health.php, referer: https://yourwebsite/wp-admin/site-health.php?health-check-test-wp_version_check=1

Probably most people try to protect wp-admin, by adding VPN IP address, but forgetting to add local server IP.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.