0

I migrated my site to another server with a migration plugin, and everything seems ok. But it is the Hello World sample post which is loading, not my frontpage or any of my other pages, instead the critical error on website appears.

I can access my dashboard, and everything is ok, but I can’t change theme, thats strange. Database configuration is set up to the new server in wp-config, and DNS ip changed at CloudFlare.

I can see that others are facing similar issues, but I havn’t found a solution which solves mine.

Regards

1 Answer 1

0

We cannot investigate the server-side problem this way since we don't have access to it and probably the moderator will mark it off-topic.

However, these are common troubleshooting points that you can try to fix this kind of issue: -

  • Try saving the permalinks for once and refresh. Go to Admin Dashboard > Settings > Permalinks > Save Permalinks
  • Check what is exactly the critical error. Go to wp-config.php and add define( 'WP_DEBUG', true); define( 'WP_DEBUG_DISPLAY', true); This will start displaying the actual error instead of just saying critical error.
  • Do you see other posts or content in the backend? Since you said Hello World is loading fine but not others. This seems like old site database is not imported correctly. Import the DB again.
  • Hire an expert to investigate and fix the issue via Upwork (mine) etc.
2
  • Thanks, I think you are right, it's because the old site database is not imported correctly.
    – calu
    Dec 4, 2022 at 10:16
  • Please accept the answer if I send you to right direction :)
    – Aqsa J.
    Dec 5, 2022 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.