1

added three links by request of a international shipping company. Added the code to the head.php doc in my theme folder.

Cleared the page cache and re-uploaded the theme cache. When I look at the source code the url has been changed to HTTP from HTTPS. Any way to fix that?

  • Just add 's' again? – Manoj Kumar May 15 '15 at 16:02
  • the file is called out with https: but if you view source it is changed to http: – Ken May 15 '15 at 23:37
0

I figured it out. I had a plug-in "Wordpress HTTPS" it was forcing all but my woocommerse pages cart and checkout page to be http:. Woocommerse already has a setting to force Cart and Checkout page to be HTTPS so I really did not need the other plug-in, so I deactivated it. I then noticed that the pages were not being forced to be HTTPS. I ran https://www.whynopadlock.com/ and found 6 images in the header that were called with the http in front of the src=. I removed the http://www.thewebsite and that fixed the issue. now just my cart and checkout pages are https with a lock and the rest can be whatever i want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.