1

I have a WordPress site that I was running every page over SSL for the past year. I just added a new website to the same server and have to share IP with the new site and the new site needs SSL much more then the old site. So I have gone through the process of changing all my https links back to http. My site loads fine now over regular http except I have 2 issues.

1) When I view source, it is showing a lot of stuff still linked to https however none of it is from the Database. IT is instead all places where home_url() is used to generate the URL! I have done a search and replace of the whole entire database to ensure all https links are back to http however it is acting as if my sites URL is still HTTPS when I call the WordPress settings for the URL.

2) Because of this bizarre behavior I cannot access my Admin panel as it redirects to https now!

Like I mentioned the database does not contain HTTPS anywhere anymore. I have no plugins that force Admin or anything to use HTTPS either. So I cannot for the life of me understand why home_url() prints out an https URL instead of http when the DB has all http url's.

Also note these details...

  • that I do not have any caching!
  • I have deleted all Transients as well
  • There is nothing in the htaccess file that is making my admin panel redirect to https yet it does redirect to https which no longer exxist so I cannot login to admin panel anymore.
  • All database files have been updated and converted from https to http in every wordpress related table. posts, options, etc...
  • There is no plugin that I can see that would be doing this so far
  • I also do not see any code in my functions or any other included custom file that would be changing my home_url() function into https
  • There is nothing in my wp-config.php file causing this.
1

Have you checked the database?

Especially "wp-options" and there the key "siteurl".

Best would probably be to do a complete dump, search for https://www.yourdomain.com and replace it with http://www.yourdomain.com

  • Yes I mentioned several times that was done, but thanks anyways – JasonDavis Jun 21 '14 at 12:38
  • Strange. Especially the backend issue is a clear sign for a wrong entry in the wp_options table. My next steps would be to double check that. Doing a query inside the template directly on the database and echoing that very value I stated above. One possibility would be that you altered the wrong database. – Christoph Daum Jun 22 '14 at 5:32
  • Another thought: why do you change to http with your primary site. True that an ssl certificate is bound the ip and domain. But unless I'm totally mistaken you can have a second domain on the same server and ip. You just can't have a second ssl certificate on the same ip. Not the answer to your question but would solve the problem in the end. – Christoph Daum Jun 22 '14 at 5:38
  • Strangely after about a day or 2 it corrected itself...the only thing that I can think of is it was some sort of Database cache where it was not pulling the actual database value...first time I ever experienced this problem though. The reason I couldn't keep using SSl on this site is my new certificate is tied to 1 domain name which is my 2nd site – JasonDavis Jun 23 '14 at 2:46
  • @ChristophDaum You can have multiple SSLs on a single IP via SNI. This wasn't always the case, but apache has supported it since 2009. – Mathew Tinsley Jun 14 '15 at 16:59
0

Add this code at the bottom of your wp-config file:

define('WP_HOME','http://www.yourdomain.com');
define('WP_SITEURL','http://www.yourdomain.com');

Just add the exact domain as worked in the past, if you used a simple domain.com without www then delete the wwww from the above code and don't forget to change "yourdomain" with your Url.

  • I had tried all this stuff. It seems my database server was for some reason caching old data values for hours that day. Never did figure out why but it resolved itself in time and served the new fresh data – JasonDavis Apr 19 '16 at 14:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.