1

I have just started working with a WordPress 3.9.2 site which has the WordPress HTTPS module active and functioning. Plugins, CSS, images, are loaded over https.

In General Settings the WordPress Address (URL) and Site Address (URL) are set to https: as well.

However there are troubling occurrences of non-https links generated by WP. The site navigation continues to link to http: even after being loaded and re-saved in the editor. The Admin View Site link is to the http: site.

In the theme home_url() generates an http: link! <?php echo esc_url( home_url( '/' ) ); ?>

Is this normal WordPress behavior? How should I correct the link protocols?

UPDATE - so the HTTPS module has a setting labeled "Any page that is not secured via Force SSL or URL Filters will be redirected to HTTP." When this is set to true you have to have edited the pages and posts and set them to Force SSL or - like it says - it redirects to HTTP. When this was set to false and saved the menus were set to the protocol of the page that was loaded.

2

This should not be default behavior.

The home_url template tag retrieves the home URL for the current site, optionally with the $path argument appended. The function determines the appropriate protocol, "https" if is_ssl() and "http" otherwise. If the $scheme argument is "http" or "https" the is_ssl() check is overridden.

http://codex.wordpress.org/Function_Reference/home_url

There are filters involved so perhaps a plugin or theme code is breaking things.

You should update to the current release as soon as you can.

  • Thanks. This affirms what I thought- that something is rotten in there. As soon as can will update to 4.0 but it's a new client and I'm still working on getting ftp, cp, mysql access and if it chokes on the updates there'll be hell to pay! – jerrygarciuh Oct 17 '14 at 0:12
  • so the HTTPS module has a setting labeled "Any page that is not secured via Force SSL or URL Filters will be redirected to HTTP." When this is set to true you have to have edited the pages and posts and set them to Force SSL or - like it says - it redirects to HTTP. When this was set to false and saved the menus were set to the protocol of the page that was loaded. – jerrygarciuh Oct 20 '14 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.