0

I need to move my WP install. Domain name is the same. This is what I did:

  1. I backed up the DB and "wp-content" folder.
  2. I installed fresh WP install on new server
  3. I emptied the DB of the fresh install and imported into it the content of the old DB (because prefix rules prevent me to create a DB carrying the same name as old DB)
  4. I replaced the "wp-content" folder of new install by the "wp-content" of old install

Now I have the new DB (containing old content) with the new "wp-config.php" that comes with it. Yet I get a blank screen. Why?

6
  • 1
    I had that problem once, couldn't figure it out though. I took this route to fix it. It is obvious that you have your details of your db and a back-up as well. Delete your wp-config.php. Because wordpress can't find wp-config.php it will automatically take you to setting up a wp-config.php. When asked for db details, enter the details of your db. Wordpress will now create a new wp-config.php and you should be able to see your site normally. One thing I would advice is to flush your permalinks when you log in – Pieter Goosen Apr 3 '14 at 11:35
  • Is there still a index.html in your root? that could couse the problem. – Maartje Apr 3 '14 at 12:45
  • 1
    are you able to login into wp-admin? errors are enabled? – ehmad11 Apr 5 '14 at 9:13
  • The WordPress SEO plugin was the culprit, not sure why/how. Renaming its folder through FTP to deactivate it solved the issue. – drake035 Apr 9 '14 at 19:24
  • I know it's obvious but no-one's mentioned logging; always worth checking what the HTTP response code for the blank page is, especially on new / unfamiliar servers, then tracing it back. Recently had an unhelpful 500 error in the Nginx access log, which needed multiple changes to the php-fpm config, besides the usual WP_DEBUG constants, to actually write the errors somewhere. – William Turrell Apr 7 '15 at 19:21
2

I think the active theme name is overridden . Check the 'option_name' => 'current_theme' value in wp_options . Is the option_value the same as your active theme name?

1

I had a similar problem. I was using a custom theme. When I moved things to a new server I started facing white screen but I was able to login to wp-admin. I updated my theme and activated again. It then started working.

See if that works for you. Just update / reinstall theme & activate again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.