0

I was trying to move a https site (on an add-on domain) from one server to another server. Both these servers (old and new) are on same host (GoDaddy) Below is the set of steps I did in that order:

On the old server:

  • Exported DB backup as sql.
  • Zipped and copied the whole content from /public_html/example.net to my local as a backup

On the new server:

  • Created a new DB and imported the SQL
  • Created a new folder under /public_html with the name example.net
  • FTP’ed the zip file and extracted here – /public_html/example.net
  • Updated wp-config with new DB credentials
  • Changed the DNS of the domain to point to new server
  • After waiting for 24 hours, I added the new add-on domain in new server and pointed it to /public_html/example.net

Now when I hit http://example.net/ or http://example.net/wp-admin it is showing a white page.

What am I missing in my steps? Any guidance, please?

EDIT:

  1. I read online for possible solutions and ensured there is no index.html under /public_html/example.net
  2. I also renamed plugins to pluginsx to see if it is a problem caused by any of the plugins and that did not help either
  3. I added the below code in wp-config.php and that does not help either

     define( 'WP_HOME', 'http://example.net/' );
     define( 'WP_SITEURL', 'http://example.net/' );
    
0

Check the wp-options table and fix the two URLs in there to your site's URLs. Then remove the URLs you added to the wp-config.php file. (That setting in the wp-config.php file overrides the wp-options table, but I don't recommend that way of setting up the site URLs - set the URLs in teh wp-options table. (That won't fix the problem, it's just a better way to set up the URLs, IMHO.)

Then, take a look at the error.log file. That's going to tell you why you got a white screen. Post that here as an added part to your question. Without the error message, it's just a guessing game. Renaming the plugins folder is a start. You could also rename the active theme's folder, which will force WP to use one of the 'twenty' themes.

ALso, take a look at your htaccess file for the old URL.

But the error.log file is the file that you need to look at for clues to your issue.

When you get it all working, use a Search and Replace plugin to change all old URLs to the new one. (I like the 'Better Search and Replace' plugin.) Media entries have the URL 'inside', so you have to change them.

Once you get all working again, and fix all URLs, use the Network tab of the Inspector (F12) to check all requests for the proper URL.

  • Thank you, Rick! I removed the .htaccess file totally. Still no help. The error log says, "PHP Fatal error: Unknown: Failed opening required '/home/example/public_html/wordfence-waf.php' (include_path='.:/opt/alt/php71/usr/share/pear') in Unknown on line 0" However, my folder structure is, /home/public_html/example Here example is the domain name. – Bhavani Kannan Jul 3 '19 at 9:13
  • In the old server, the site files were directly under the public_htm folder. In the current server, I am hosting it as a add-on domain which means the site files will be under public_html/example folder. Besides the URL / domain of the site did not change. I am just moving the site to a new server with the same hosting provider. – Bhavani Kannan Jul 3 '19 at 9:16
  • Did you change the URLs in the wp-options table to the correct place? Can you place a simple HTML file in that file location and access it? Have you made sure that the domain in hosting is pointing to the correct file location? And that error message indicates a problem with the "Wordfence" plugin, perhaps? And clearing caching? – Rick Hellewell Jul 3 '19 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.