1

I am unable to install plugins on my Centos 6 VPS. When I attempt the install I get this:

Installing Plugin: BotDetect WordPress CAPTCHA 3.0.Beta1.7

Downloading install package from
[web path to:]botdetect-wp-captcha.zip…
Unpacking the package…
Could not create directory.
Return to Plugin Installer

UPDATE: This seems to have something to do with permissions -- I'm guessing there's some group that wordpress needs to be part of in order to change folders, create files, etc., but I can't figure out what that group should be. I have no www-data group -- I read something somewhere about this being a requirement. Can somebody tell me what groups and permissions need to exist for WP to operate?

UPDATE: I have chmodded the permissions to my plugin and uploads folders to 777. I also have created an FTP user specifically for Wordpress and made the home directory for that user the same as my Wordpress root folder as recommended HERE. I then changed these lines in the wp-config.php file from:

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__ . "/"));

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

to:

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__));

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . '/wp-settings.php');

This should eliminate the double slash conflict mentioned HERE.

Note -- I was also having a problem uploading media but that issues was resolved with the chmod to 777.

Now when I try to install a plugin I get this:

Unable to locate WordPress Plugin directory.

Return to Plugin Installer
1

Okay, I figured this out based upon suggestions from StackOverflow. This is how I resolved this issue:

I created a group called ftpusers.

groupadd ftpusers

I added my wordpress user to this group.

usermod -a -G ftpusers wordpressuser

I changed ownership of the wordpress folder recursively to my wordpress user:group.

chown -R wordpressuser:ftpusers wordpress

Voila -- my package installed.

0

This problem doesn't seem to be regarding CentOS but the permissions of your folders. Try creating the plugins folder in your wp-content. If that doesn't work try CHMODDING 755 or 777 (though this may be risky, try just for testing purposes) on the newly creating plugins folder.

  • I had already created the plugins folder under wp-content and it was 755. I changed it to 777 and still the same problem. I tried using an alternate FTP user/pw combo and got this: Unable to locate WordPress Content directory (wp-content). Return to Plugin Installer – user1780242 Dec 18 '13 at 21:48
  • I had this problem a while ago. I tried a fresh install of WP and everything had been fixed. You may want to wait for another answer. – Bobby-Joe Audet Dec 18 '13 at 21:51
  • Actually, it is a fresh install. I just added wordpress to my site. – user1780242 Dec 19 '13 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.