I recently transferred my Wordpress Site to a new host. I have almost everything working, except for the plugin auto installer.

If I search for a plugin and install it, it works just fine.

If I try to upload my plugin from my computer, I get this error message:

Download failed. A valid URL was not provided.

I can manually install the plugin through my FTP client, Cyber Duck, by uploading the folder and activating it in the plugins list.

I have set all my permissions to 777 on my plugins folder. I do not see anything in my server error logs period.

I've had a lot of problems with setting permissions with the transfer, so I think that may be it.

Can someone help?


1 Answer 1


Was your plugin uploaded to /uploads directory on the server after you pressed "Upload"? If "Yes", have you added "Connection Information" after that? If "Yes" again, it could be server configuration issue.

  • Okay, yes, it does upload into my uploads directory. Which, I didn't think so at first, but then saw it in my media library when I went to add a picture. I don't understand what you mean by adding connection information though.. Why are my plugins going to my uploads folder instead of my plugins folder?
    – snowlas
    Mar 27, 2012 at 19:32
  • 1
    Okay, got it to work. My pictures weren't uploading correctly either. So I went to Settings>Media and filled in the Full Path URL with mysite.org/wp-content/uploads and now both the pictures upload and plugins upload correctly! Voila! Two birds with one stone.
    – snowlas
    Mar 27, 2012 at 19:58
  • Firstly plugins goes to /uploads, then they are getting copied to /plugins using your FTP connection information.
    – Max Yudin
    Mar 28, 2012 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.