1

I just finished setting up Wordpress on my apache webserver, but now I'm having this problem which is pretty much preventing me from doing anything with my site. Whenever I try to install or update a plugin I always get the following error:

Username/Password incorrect

Which I know cant be possible because Im providing the correct credentials. When I try to update Wordpress to a newer version I get:

There was an error connecting to the server, Please verify the settings are correct.

The credentials I'm using are as follows:

hostname: localhost

FTP username: fender

FTP password: the password for fender

I can connect via FTP using that same username and password with with Filezilla or any other SSH program with no problems, so I don't know why it isn't accepting the credentials. I thought it was maybe a permissions issue so I tried CHMOD 777 within the wordpress directoty and that still didn't work. I'm completely lost as to what may be the problem, and it cant be a hosting thing since it's my own server as well. I have even tried installing plugins manually via FTP(updraftplus to be specific) and it wont even show up on my plugins page after extracting the folder to the plugins directory. Any ideas?

  • I am sure you don't connect over FTP with Filezilla using "localhost" as the host name. Whatever host name you use, try that one. – s_ha_dum May 4 '15 at 20:33
  • hostname is cokongwu.com. I've tried that as well and get the same result – onemic May 4 '15 at 20:34
  • If you have control over your apache config, use suphp/suEXEC as the php handler. Using dso or something else usually gives those kind of issues you are describing. – gdaniel May 4 '15 at 20:38
  • @gdaniel Sorry, but Im kind of a newbie to apache/linux. How do I change the PHP file handler to suphp/suEXEC? – onemic May 4 '15 at 20:41
1

Fixed it. Put in a few commands that helped give wordpress the permissions it needed to auto update:

sudo usermod -aG www-data $USER


sudo chown -R www-data:www-data /var/www


sudo chmod -R 774 /var/www

This problem has been plaguing me for months. I feel like a huge weight has been lifted off my chest now haha.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.