I have several installations of wordpress on my vps and I have a couple that add/update plugins with no problems.

When adding a new plugin I get the following progress messages:

Downloading install package from http://downloads.wordpress.org/plugin/hello-dolly.1.6.zip
Unpacking the package…
Installing the plugin…
Successfully installed the plugin Hello Dolly 1.6.
Activate Plugin | Return to Plugin Installer

However, on most of my WP installations the message stops at the first line:

Downloading install package from http://downloads.wordpress.org/plugin/hello-dolly.1.6.zip

The plugin is in the plugin list when I check and all I need to do is activate it. Also, when updating a plugin it doesn't reactivate, so I have to manually do it myself. On a working installation the plugin is reactivated automatically.

I've tried cross referencing folder permissions with WP installations that work but I'm having no success.

If anyone could help, I would appreciate it, I find it very annoying and tedious when I have to update everything manually.

  • Got access to PHP Error Logs at all?
    – Alex Older
    Apr 25, 2012 at 14:40
  • Hi Jason, do you have any security plugins installed that could be interfering with this process, e.g. AskApache Password Protect? Alternatively you could try setting your plugins folder permissions to 777 temporarily and see if this makes any difference when updating. Apr 25, 2012 at 17:51
  • Hi Andy, Tried that before I posted, needless to say it didn't work.
    – Jason
    Apr 26, 2012 at 15:00

2 Answers 2


I have several installations of wordpress on my vps...

You need to look in your error logs and find out if it is a permissions problem or something else. Everything will be in the logs on a VPS, unlike cheaper shared hosting. Google "error logs" for the OS of your VPS.


On some webhosting configurations, Wordpress automatic updates fail. In my experience, if it is not file permission, then it is an issue related to file ownership. Try the FTP method. Add the following lines in your wp-config.php

define('FS_METHOD', 'ftpext');
define('FTP_HOST', 'YOUR FTP HOST (without http:// or ftp://)');
define('FTP_SSL', false);

If still a no-go, see: http://codex.wordpress.org/Editing_wp-config.php#Override_of_default_file_permissions for alternative methods.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.