0

I tried uploading two blog posts for my job(they were recipes and had nothing to do with Shopify whatsoever) and then the blog part of the site crashed. I was left with this error:

Fatal Error: Uncaught Error: Call to undefined function get_plugin_data() in /home1/ourname/public_html/blog/wp-content/plugins/wp-shopify/index.php:15 Stack trace: #0
/home1/ourname/public_html/blog/wp-settings.php(342): include_once() #1 /home1/ourname/public_html/blog/wp-config.php(89): require_once('/home1/ourname...') #2 /home1/ourname/public_html/blog/wp-load.php(37): require_once('/home1/ourname...') #3 /home1/name/public_html/blog/wp-blog-header.php(13): require_once('/home1/ourname...') #4 /home1/ourname/public_html/blog/index.php(17): require('/home1/ourname...') #5 {main} thrown in /home1/ourname/public_html/blog/wp-content/plugins/wp-shopify/index.php on line 15

How does my coworker, who's the actual admin, fix this issue and get the site operational? She tried to get the site up using Firezilla, but it says the server can't connect. Then she called GoDaddy, who said they don't host our site. We contacted the previous admin who said it's hosted through Arvixe.

I asked her to disable the wp-shopify plugin but she said she's never seen that plugin before and neither have I. We'd greatly appreciate any help you can give us! Thank you.

  • The only fix here is to disable the Shopify plugin, and to do that you'll need FTP or cPanel (or similar) access. No one here can help you with that. You need to talk to your host. – Jacob Peattie Jun 25 at 11:43
  • FWIW this appears to be a legitimate (i.e. not from a hack) bug in this plugin: wordpress.org/plugins/wp-shopify They're using this function on all pages when it's not available on the front-end. – Jacob Peattie Jun 25 at 11:46
0

Filezilla is just an FTP client, it sounds like you have the wrong credentials to login. Either the host name, username or password is probably incorrect.

You best bet, for fast results would be to contact your host. If you are unsure about who your host is you could try a tool like this.

You should be able to disable the plugin by going to Admin > Plugins. If you don't see a plugin menu it is likely your account isn't an administrator account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.