0

I'm getting locked out of */wp-admin/ there is an error log. Its after changing php 7.2 to php 7.3. The error doesn't disappear even if i go back to php 5.6 where MySQL_connect function exists and is used.

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/punkmmur/public_html/wp-includes/wp-db.php:1564 Stack trace: #0 /home/punkmmur/public_html/wp-includes/wp-db.php(592): wpdb->db_connect() #1 /home/punkmmur/public_html/wp-includes/load.php(409): wpdb->__construct('punkmmur_calyps...', '7S4T]52!pg', 'punkmmur_calyps...', 'localhost') #2 /home/punkmmur/public_html/wp-settings.php(106): require_wp_db() #3 /home/punkmmur/public_html/wp-config.php(93): require_once('/home/punkmmur/...') #4 /home/punkmmur/public_html/wp-load.php(37): require_once('/home/punkmmur/...') #5 /home/punkmmur/public_html/wp-admin/admin.php(31): require_once('/home/punkmmur/...') #6 /home/punkmmur/public_html/wp-admin/index.php(10): require_once('/home/punkmmur/...') #7 {main} thrown in /home/punkmmur/public_html/wp-includes/wp-db.php on line 1564

Restoring website does not work. I disabled all plugins via phpmyadmin and by renaming folders in ftp. I changed theme to default too. Now even if i come back to my theme, some pages stay stuck on default theme even if i clear browser cache. Website is accessible: Tatouage Calypso, Tattoo Québec.I can't access wp-admin Maria DB is up to date. I tried multiple restores. Wp super Cache is deactivated i even trued to define to false the wp-cache entry in wp-config.php, i even added site url and home url in wp-config.php. I tried renaming .htaccess, i renamed theme directory to force fallback to default theme.

  • There error log is a log. It's still going to have the errors even if you fix the problem. The question is whether new errors are being added to the log. – Jacob Peattie Jan 9 at 5:25
  • It was always the same log that appeared i don’t know if it was added every time. – RastaDjust Jan 29 at 20:51
0

The problem was nd_mysqli php modules not activated for 7.2-7.3 but that still doesn’t explain why restore didn’t work once activated it worked but had some webmaster fix it for me. Maybe caching but i kept flushing caches.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.