0

Updated my query below in detail. I found the below error in my error.log which causing unable to load my WordPress dashboard. When I try to log in, it is redirecting to the home page. WordPress database error:

Table 'wcdsnjor_wrd1.1688063712_wddw_users' doesn't exist for query

                SELECT 1688063712_wddw_users.ID
                FROM 1688063712_wddw_users
                WHERE 1=1
                ORDER BY user_login ASC

made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), WP_Hook->do_action, WP_Hook->apply_filters, Code_Snippets\Upgrade->run, Code_Snippets\Upgrade->do_site_upgrades, get_users, WP_User_Query->__construct, WP_User_Query->query

Tips I tried to resolve:

  1. Checked all file and folder permissions
  2. Removed .htaccess file
  3. Renamed plugins folder (getting blank screen)
  4. Switched to Default theme (getting blank screen)
  5. Added memory limit to 256 in wp-config.php
  6. Created a new admin user through functions.php and tried login
  7. Rollback to the older version of WordPress i.e. 6.2.0 & 6.1.3
  8. added define('WP_ALLOW_REPAIR', true); in wp-config and did the repair of 1688063712_wddw_users table.
  9. defined site url, home url in wp-config like ex: define('WP_HOME','https://siteurl/'); define('WP_SITEURL','https://siteurl/');

Nothing worked. For the first time when I'm trying to access wp dashboard, it is redirecting to home. If I enter siteurl/wp-admin again in the same window, it is throwing like: Sorry, you are not allowed to access this page.

But, all the folder and file permissions are properly set and the memory limit is also set to 256M through the config file.

Can anyone help me on this?

Thanks in advance.

3
  • Best bet is to disable recently installed plugin(s) to see which one is causing the issue. There also might be other info in the error log file as to the code files that are finding the error. Report back (edit your question) if you have more info, and add your own answer if you figure it out. Jul 10, 2023 at 22:39
  • Hi @RickHellewell I have updated my question with full details. Please check. Thank you. Jul 11, 2023 at 6:08
  • 1
    Do you have a plugin called 'Code Snippets'? Have you tried one of the "twenty" themes? Check your 'mu-plugins' folder? Looked in the users table for users that shouldn't be there - and is there at least one 'admin' level user? Manually reinstalled all WP files (execpt the wp-config.php file, which you should have a backup of)? Anything funny in the wp-config.php file (and others - and make sure you scroll to the end of the file; some hacks will add a bunch of blank lines to a file before they add their code, and turn on wordwrap when viewing)? Jul 11, 2023 at 21:33

1 Answer 1

0

Please upload the wp-admin and wp-include folder with the fresh files and remove the old wp-admin and wp-include folder full. and remove the all .htacess files from each and every directory of wp-content folder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.