0

I got this error when I tried to open my dashboard after doing an automatic Wordpress update. My website is still showing up normally; I just can't access the dashboard to work on it. Previous answers to the same problem elsewhere online suggested clearing the cache and manually updating Wordpress using FTP. I've tried both of these things, but they didn't work. I can't find any other suggestions, so I'm asking here. How can I fix this problem? Please try to be detailed in your instructions, as I am just a layperson with a website and not a developer. Thank you!

  • do you have backups from before the update? Files & DB? I'd suggest trying to go back. – rudtek Sep 1 '17 at 19:40
  • No... I know that's bad, and I should have made backups, but I didn't. Is there anything else I can do? – Jana Sep 1 '17 at 20:16
  • Although I do see a folder in my FTP called "blog.old" (the website's root folder is "blog"). I'm not sure what this means... Is it a backup? It's been a very long time since I updated my site, so I can't remember if I made this folder somehow. – Jana Sep 1 '17 at 20:19
  • It also says the error is in "wp-admin/admin.php on line 141." Is there some way to fix this manually? Sorry for the repeated comments. – Jana Sep 1 '17 at 20:26
  • You would need the db too. Check the dates on the files / directories on the .old in ftp. – rudtek Sep 1 '17 at 20:30
0

I think you first need to verify whether a plugin or theme is causing the problem.

Temporarily rename the wp-content/plugins folder to something else, then access the admin panel. If the problem does not reoccur, recreate the wp-content/plugins folder, then move plugins' folders in there in small groups to determine a suspect. You may need to activate those plugins.

If you can get to the admin page with plugins disabled, do a WP core update via the Updates page. Then start eliminating plugins.

If the problem is still there with wp-content/plugins folder renamed, rename non-default themes (in wp-content/themes) folders (the ones that aren't 'twenty-something'). That will cause your theme to default to the WP-supplied one. Get into the admin page and do a WP core update.

Then restore themes and activate them as needed until you find the culprit.

I suspect a plugin before a theme. And know that this will cause your site to be a bit 'goofy' because plugins are disabled. But that is what I would do.

  • Thanks for the suggestion, but I'm afraid it didn't work. The same error is still displayed. :/ – Jana Sep 1 '17 at 21:59
  • Increase memory limit. Place this temporarily in the wp-config.php file: define('WP_MEMORY_LIMIT', '64M'); (semicolon at the end required). Then try access the admin page. (If that line is already there, adjust the values, removing any '#' from the beginning of the line.) – Rick Hellewell Sep 1 '17 at 22:35
0

Here are a few options, mostly to identify where the function is:

  1. If you have SSH access you can login and go to your website's directory (eg. cd /path/to/public_html/ then do: grep -R "wp_raise_memory_limit" * ... this should locate where the function is being called that doesn't exist.

  2. Similarly, but without SSH, download the entire site via FTP (yes a bit of a pain to wait, but you could do it a bit at a time also, start with the wp-content/themes/ and /wp-content/plugins/ folder)... then use a program such as Textpad to Search -> Find in Files for the text wp_raise_memory_limit within the files downloaded locally.

  • Okay, I don't know what SSH access is, so I assume I don't have it. The error message actually said the error is in "wp-admin/admin.php on line 141." I searched the admin.php file from the Wordpress update for that text and found this line: if ( current_user_can( 'manage_options' ) ) { wp_raise_memory_limit( 'admin' ); } Can I somehow edit this line to fix the error? – Jana Sep 1 '17 at 22:18
  • just rename wp-admin to something else then, the important thing is you re-upload the original (matching) wp-admin files for your version of wordpress. – majick Sep 2 '17 at 1:00
  • ...and you may want to do the same with wp-includes folder as it is also possible the corruption is found there. – majick Sep 2 '17 at 1:02
-1

So guess what? I just tried downgrading to the previous version of Wordpress, and that fixed it! I guess there must be some sort of bug with the latest version. I will definitely make sure to back up my website now though, just in case. Thanks everyone for trying to help!

  • actually just sounds like the upgrade got corrupted or didn't complete, if there were a bug in the latest version, millions of websites would have gone down in the same way. – majick Sep 3 '17 at 9:17
  • Okay thanks, that makes sense. Maybe I should try the upgrade again. – Jana Sep 4 '17 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.