0

Recently I've received a task from my clients to improve their company page. I've migrated the page to my VPS and made some modifications:

  • added new content
  • updated Wordpress
  • updated plugins
  • updated theme (Salient)
  • fixed minor CSS issue

Next I've moved the page back to the original hosting (home.pl) and I've begun testing. Everything has worked well so far but when I've clicked the button "update" on any page, something strange has happened: I've been moved automatically to the posts list and all my changes haven't been saved.

I've tried testing different things but I can't come up with a solution. Disabling all the plugins and theme doesn't help. When I create new page and put little content I can save and modify page, but when I put a lot of content it doesn't work.

I've tried wp_debug and chrome console but it gave me "Failed to load resource: the server responded with a status of 404 (Not Found)" error.

I've tried increasing, max_execution_time, max_input_vars, memory_limit. And obviously I've googled for a solution but with no results.

Website works fine on my VPS but it' doesn't work on client's hosting. What else can I try to solve this problem? Any ideas?

Web page uses Salient theme with WPBaker Visual Builder. I've noticed that the original size of .sql dump was ~50MB. but after my changes it's grown almost twice the size.

Thank you.

  • Can you provide some examples of the errors you're seeing in the console and/or the network panel? Depending on the resource that's throwing the 404, that could be the issue. – MikeNGarrett Apr 3 at 22:47
  • Did you change the URLs in the wp-options table to show the new site URL? – Rick Hellewell Apr 3 at 22:52
  • @RickHellewell Yes. All the URLs are fine. Web page from user perspective works without a flaw. Only problem is that I cannot edit any more complex post/page. I don't get any error in the console besides error 400 from admin-ajax.php – user2660811 Apr 3 at 22:56
  • admin-ajax.php is used for a variety of actions from the WordPress admin. If that's missing, it's going to cause problems. 400 errors indicate something totally different from 404 errors. Please provide some further details in your question. – MikeNGarrett Apr 3 at 23:02
  • I create a new post, put a little bit of content and then hit "publish" and it works fine. Then I edit it, put a little bit more content, hit "update" and still works fine. Then I edit it again, put a lot of more content, hit "update" and nothing happens. I get redirected to "posts" page. Looks like the size of the content matters. I get 400 error just after clicking "update". – user2660811 Apr 3 at 23:07
0

I would first do the same procedure you outlined in your comment with one of the 'twenty' themes. If that fails, then I would temporarily disable the plugins 2-3 at a time to see if that makes the problem go away.

Also, just for grins, do a reinstall of WP from the Admin, Update page.

And, I would check the version of PHP on the server, comparing it to the development server. I'd aim for PHP version 7+ if at all possible.

If going to one of the 'twenty' themes doesn't fail, then I'd contact the theme support. Likewise with a plugin that appears to be causing the problem.

Use your test procedure after each change. And backups of the database before you start making changes might be good also.

  • Thank you for your answer. I've already tried everything you mentioned. Looks like I just need to contact hosting provider and theme support. – user2660811 Apr 4 at 0:06
  • Assume that you also have looked at the Network tab in your browser's developer tools to see the actual request that is causing the 404? And looked at the server access logs, as well as the error.log file in the WP folder (and look for other error.log files in the WP file structure). – Rick Hellewell Apr 4 at 1:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.