0

my issue is similar to the one addressed in this question (WP won't save changes in post (any)

Long story short: all of a sudden 3 wordpress install stopped working. I type a post, hit "save as draft" - or publish - and everything seems fine at first look, but actually the post is not saved. If I go back to the dashboard > All posts, the post has been saved with title "Quick draft" and is completely emtpy. Also permalink is not saved. Oddly enough I can save a draft post using the dashboard home feature - the small box that lets you add content quickly from the dashboard home page. I can also upload images but I cannot set a featured image - the loader keeps spinning but the image is not attached to the post.

I suspected a cache issue, so I cleared the cache from my Hosting panel, but had no luck. I tried the Health Check diagnostic, but the plug-in diagonstic was fine. I disabled all the plug-ins, reverted to TwentyTwenty theme, cleared cache again, but still no way to save a post.

I contacted the hosting provider had a chat with a customer care rep who flushed the cache and I manage to save one post, but after that I had the same problem again. Wordpress is up-to-date (version 5.5.1) and the dev versions of two of the websites work on my local install - so I don't think it's a plug-in conflict. As a workaround I managed to write the post on the local version, export it and then importing on the live website and it works, except that the post doesn't have a featured image (it doesn't get imported).


EDIT I tried to add a new post using the Classic Editor plug-in that I deactivated long ago. And now I can save posts as long as I keep on using it. So Gutenberg seems the problem. This is just a workaround, unfortunately.


The hosting provider says it's a development issue and I should ask a developer, since everything's ok on their side.

Any suggestion before changing the hosting provider?

20
  • It does sound like a development issue to me, but try deactivating all plugins, switch to the Twenty Twenty theme (which I presumed was never modified?), and reinstall WordPress via the Dashboard → Updates page. Then see if those steps help. – Sally CJ Sep 29 '20 at 15:06
  • Hi Sally, thanks for the suggestion. I tried deactivating everything and switch to TwentyTwenty and nothing happened. I haven't tried re-installing Wordpress from the dashboard, though but it looks like a good idea. I'll try later today as soon as I have finished doing a backup. I also tried to re-activate the Classic Editor - I haven't used it since Gutenberg launched and now at least I can save the posts - I'll edit the original question. – kikaweb Sep 29 '20 at 15:31
  • Hello @SallyCJ, I tried to reinstall Wordpress via the Dashboard but the problem persists. – kikaweb Sep 29 '20 at 15:43
  • This certainly wont be a hosting issue. If it's only affecting Gutenberg then it might well a JS issue. My bet is that it's plugin related. I'd try deactivating those one by one (with Gutenberg back on) and keep checking. – vancoder Sep 29 '20 at 17:47
  • 1
    The problem is solved, but since I don't know how it happened I won't post an answer. After removing some malicious files hidden in my WP installs, and after the support downgraded the PHP version to 7.1, everything works. Honestly, I don't know what did the trick, but I wish I knew. Thanks to @SallyCJ for supporting me through the troubleshooting. – kikaweb Oct 8 '20 at 21:27
1

Following advices from other contributors I'm posting here the "solution" for future reference, just in case someone is experiencing the same issues.

As I wrote in one of the comments, while investigating the REST API problem - by the way, I'd have never narrowed it down without some help from @SallyCJ - I found out some malicious files in all three Wordpress installs. I wasn't looking for malware or exploits, I simply stumbled upon some suspicious php files that weren't supposed to be on my server. Hosting support helped me doing a thorough security scan, so I could remove all the nasty files.

I don't know why but when the malicious files where detected the support staff automatically downgraded my PHP version from 7.3 to 7.1.

Honestly, I don't know what did the trick - the cleaning or php downgrade - and even the support staff had no clue, but right now all the websites are working, I can post new content using the block editor and everything seem to work just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.