1

I was trying many plugins to achieve a goal which is to create a custom registration field and profile page. I used ultimate member, profilepress, login press, peter's redirect, pie register and a few others.

Each plugin i install would create a new login and registration page like mydomain.com/login-2/ mydomain.com/log-in and so on.

I got irritated by the pages so i decided to delete one by one. After deleting few of the pages. i logged out to test something and now i cannot login anymore.

Each time i tried mydomain.com/wp-admin it takes me to mydomain.com/login-3_trashed and a follow up of some long link.

Since then i've not been able to login to my dashboard.

I understand, those plugins i installed had changed the default wordpress login url to theirs and i have accidentally deleted the page.

Some google results suggested i disable all my plugins using ftp and myphp but i am not familiar with such things and i don't want to mess up anything because i did not backup.

I think i can do a few things around file manager only. so please i need help around this issue. the url is ijmbexam.org.ng/wp-admin .

You can check and see what it shows.

Thanks

  • Did you check .htaccess file and clean up you plugin cache? I think you find the solution you are hunting. – Porosh Ahammed Jun 5 '17 at 17:29
  • Could be due to WP auto-redirecting old slugs. Try deleting from wp_postmeta: wordpress.2bearstudio.com/… – WebElaine Jun 5 '17 at 17:54
  • 1
    Or, if you want to use a file manager rather than mysql, rename your plugins folder (it can be anything - for example, 'backupplugins') and that will disable all of the plugins. You'll also need to clear your browser cache/history completely or use an incognito window so your browser doesn't continue redirecting you. – WebElaine Jun 5 '17 at 17:55
  • @WebElaine your answer saved my day. i have accessed the dashboard ... but all the plugins are disabled. What do i do next to activate the plugins without getting into more trouble – Tarrmie de Man Jun 5 '17 at 18:33
  • I thing you have one because which plugins you have used they automatically push code to the htaccess to redirect your admin page. So enable "show hidden file" option from your file manager setting. Hope you will find that details HERE. If you really don't have one after trying that process then you can create one. You also read THIS – Porosh Ahammed Jun 5 '17 at 18:48
4

To solve this problem using a file manager (or FTP), rename your plugins folder. You can rename it anything - for example, "backupplugins". This will disable all plugins. You'll also need to clear your browser cache/history completely or use an incognito window so your browser doesn't continue redirecting you.

Once you can log in successfully, you should be able to rename "backupplugins" back to just "plugins". WordPress should still have them all deactivated. You can then activate them one by one through wp-admin. Log out and log back in each time to test and verify that the plugin you just activated isn't messing up the login. Once you find the plugin that is causing issues, you can rename the plugins folder one more time, log in, rename plugins folder back to "plugins", log in, reactivate all plugins except the problem one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.