0

I'm running Wordpress on a small Ubuntu 16.04 Server, with Nginx and Php 7.0. Yesterday I noticed that I didn't have the site configured correctly, so that http://example.com worked, but http://www.example.com did not. I logged into the admin console through example.com/wp_login.php and tried to update the settings, but when I clicked submit I got a blank page saying "This site is currently undergoing maintenance, and will be back shortly."

Now my website isn't displaying. When I go to exmaple.com/wp_login.php I get a plain HTML login page with no formatting. I enter the username and password and I just get a loading icon forever. No error message, no redirect, nothing. Clicking on the "forgot password" link just takes me to the same maintenance message that I had before.

So far I've read a few things and tried disabling all plugins and themes, restarting the server each time. No effect so far. What am I missing here?

0

I'm no expert, but am I understanding correctly that you logged into wp_admin, went to the Settings page and changed the WordPress Address and/or Site Address?

If so, when I ran myself into that in the past, I fixed it by doing a find and replace in my database using phpMyAdmin. I searched for the new URL (example2.com) and replaced it with the previous URL (example1.com), essentially resetting it to its previous state. If you have one, you could also restore a backup of your DB and that should fix it (a good incentive for always making a backup before you change settings or update plugins). If all you did was add or remove "www," you should be able to search for "//www.example.com" and replace it with "//example.com" (or vice versa; I included the forward slashes so you don't end up with www.www.example.com or something like that). Of course, before you make any changes, export a backup of the DB in case things get worse so you can just restore!

When I had this (or a similar) issue, I made the change in preparation to migrate the site to a different domain, then the client wanted to make some changes so I had to undo that change.

Where you actually need to make that change is probably somewhere in the server configuration or maybe even the DNS settings with your registrar (look for "forwarding" and/or CNAME records—something along those lines). If you've recently activated SSL, there may be something wrong in the way your certificate was set up.

In other words, I don't think you had a WordPress problem until you changed one or both of those URLs. Making those changes created a WordPress problem that hopefully my answer will help you fix, but I think your initial issue is more likely to be with your server or DNS settings.

Again, no expert, but hopefully that gives you somewhere to start!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.