I am trying to customize the comments template in the comments.php and so have made some changes to the code, including a call back function in wp_list_comments() (which I have defined in functions.php)

These all changes work fine on my local dev machine but somehow I cannot see any changes when I upload the comments.php and functions.php in the root directory of my theme folder.

I have tried de-activating and re-activating all the plugins but still no success. It's driving me nuts now.

Does anyone have any idea what might be wrong?


Ok I figured out the problem!

There was nothing wrong with the code or wordpress. My web host provider decided to change the IP address of my account without even notifying me. So all this time I was uploading the files on my old FTP address. That was the reason no changes were showing up on the site.

I have now wasted almost my full day trying to figure this out and makes me want to give a real hard kick up the balls of my provider...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.