I had a working (test) blog, and during an update from 3.2.1 to 3.3.1 - something went wrong , I think the update did not finished..

Just before the Update, I have enabled a new theme (all functions and files made by me )

Since the update went wrong - I can not access my admin area (500 error) but the front end works just fine ...

The same blog and theme works without a problem on local machine .

I had deleted ALL files on server (except uploads) and updated with a new version - but to no avail.

any solutions to such a problem =??

  • Have you deleted your .htaccess file too?
    – Alex Older
    Feb 6, 2012 at 15:50
  • Have you tried deactivating all plugins (by changing the names of the folders) and themes?
    – mor7ifer
    Feb 6, 2012 at 16:36
  • @ alex Older - yes , .htaccess deleted as well @m0r7if3r - I have removed the plugins folder as a whole (renaming that is ) but it is still the same..
    – user13279
    Feb 7, 2012 at 17:22
  • What about your themes?
    – mor7ifer
    Feb 8, 2012 at 0:02
  • only themes there are 2 versions of a theme I made myself , both worked before without problem..and both have no function that has to do directly with the admin area...
    – user13279
    Feb 8, 2012 at 2:33

3 Answers 3


In phpmyadmin search :

FROM wp_options
WHERE option_name = 'template'
OR option_name = 'stylesheet'
OR option_name = 'current_theme';

then :

UPDATE wp_options SET option_value = 'yourthemename' WHERE option_name = 'template';
UPDATE wp_options SET option_value = 'yourthemename' WHERE option_name = 'stylesheet';
UPDATE wp_options SET option_value = 'yourthemename' WHERE option_name = 'current_theme';

or if you want to go back to default (presuming some default exists)

SET option_value = 'default' WHERE option_name = 'template';

UPDATE wp_options SET option_value = 'default' WHERE option_name = 'stylesheet';

UPDATE wp_options SET option_value = 'default' WHERE option_name = 'current_theme';

note :

  • template – the “Theme Name” as defined in style.css
  • stylesheet – the actual name of your theme folder
  • current_theme -the actual name of your theme folder
  • 1
    Thank you ! it worked ! now i changed to default . When i got to the admin, i got a strange message telling me that the database was needed to be "updated" or "refreshed" - i do not remember . But after that - all worked like charm. life saver ! thanks again
    – user13279
    Feb 8, 2012 at 15:27
  • happy it worked . Once it happened to me too.. I do not know why, but it somehow has to do with changes in the MENU and Categories .
    – krembo99
    Feb 8, 2012 at 15:30

I received a 500 Error message after update the wordpress. However, the problem was not caused by the update process.

Your database server may corrupt a table(s). To fix this problem you should use phpMyAdmin or something else, and optimize/repair the tables.

It Works For Me!


Are there plugin installed? it's easy to make a 500 error if some plugin does something bad inside an if( is_admin() ) clause. Try to remove/rename plugins to isolate the problem.

Otherwise, just remove all files, unzip a freshly downloaded wordpress from wordpress.org, put your uploads back, and retry.

  • I have renamed the plugin dir to a temp name, and also reinstalled ..the problem is that I can not even change a theme now , it seems something in the DB searches for an unexciting theme - because after new install wordpress gives me a blank front end (typical of missing theme )
    – user13279
    Feb 7, 2012 at 17:25
  • @Obmerkronen But you should still be able to /wp-admin to change your theme. Is wp-admin accessible? it should. Go there and change your theme settings
    – boyska
    Feb 8, 2012 at 8:07
  • this is exactly the whole point of the question - my admin area gives me 500 error. the front end works just fine ..
    – user13279
    Feb 8, 2012 at 14:44
  • If you have no plugins, I really don't know what caused this. But if you can, watch the error logs. The blank page is not just "missing theme": lots of other things could be
    – boyska
    Feb 9, 2012 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.