3

I have access to the admin panel, and everything works fine. I can click settings->reading and change anything I want to. But if I click settings->permalinks I get a 500 internal server error. Here's what I've tried:

I deleted the .htaccess file - nothing changed. I edited the .htaccess (because I am migrating this site to a new domain) and now I have all the page links working on the front end AND all the admin links EXCEPT permalinks. In other words, the front-facing portion of the website works. All of the admin features work. But if I click settings->permalinks, it takes me to /wp-admin/options-permalink.php but loads my theme's index.php template. Why?

I also re-installed all WordPress core files, to no avail.

Anyone have any ideas?

Here's my current .htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
  • 2
    Errors 500 are pretty much impossible to guess. Need server logs and actual error. :( – Rarst Jan 23 '15 at 22:41
  • 1
    If you already removed your htaccess file then you need to disable all plugins and reactivate them one by one, but what @rarst said is true. 500's are impossible to guess without the error message – Rebecca Dessonville Jan 24 '15 at 1:31
0

download a copy of wordpress.zip file then unzip it, copy /wp-admin/includes/update-core.php file and overwrite the one on the problem site. that worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.