0

By default WordPress does not appear to have the option to add rel="nofollow" attributes on the RSS widgets.

<li>
    <a class="rsswidget" href="http://news.google.com/news/url...">
        The 60-Something Entrepreneur
    </a>
</li>

How can I make it so my RSS feed links have the rel="nofollow" attribute?

1

There seems to be no way to do that. You could filter 'clean_url' (like I did here), but I don't see a simple way to deactivate the filter when the RSS widget is rendered.

You could open a ticket on Trac and ask for a filter in wp_widget_rss_output() … from my experience wasted time, but there is no third option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.