1

I cannot access my admin page after disabled all of my plugins via wp-admin/plugins.php. Initially, I was trying to activate Multisite. Now, despite logged in into my admin acount, the wp-admin only says 'Sorry, you are not allowed to access this page' (or something in that line, cause I set the language in Indonesian).

I am using Wordpress 5.4.1 with PHP 7.1. It is hosted on a shared hosting and I can access using cpanel.

Installed plugins:

  • Akismet
  • Jetpack
  • Loginizer
  • Woocommerce
  • AMP
  • Auto Upload Images
  • GDPR Cookie Consent
  • Disqus
  • Menu Image
  • Polylang
  • WP Github Sync

Things I've tried:

  • Renaming wp-plugins folder to disable all plugin (doesn't work)
  • Emptying active-plugins entry in wp_options table (doesn't work)
  • Enabling WP_DEBUG (debug_log list nothing abnormal)

If you need more info, please tell me. Any help will be appreciated :)

  • Did you edit a WordPress plugins.php file? – Tony Djukic May 23 at 2:43
  • @TonyDjukic Umm no, I edited them via the menu inside the administration page. – Banitama May 23 at 8:05
2

Well I agree with @Faye. It might be due to the activated theme which is depending on one of the plugin you deactivated. But rather than doing all of the steps you can simply rename the active theme in the wp-content/themes folder via FTP or cPanel. This will deactivate the theme and if it's the theme problem then you will be able to access the admin page.

| improve this answer | |
  • 1
    I didn't know that would work! – Faye May 26 at 20:11
  • 1
    That's ok. We are all here to learn new things and explore new options every day. I, myself learn new things from stackexchange. – made2popular May 26 at 21:48
1

Sounds like your theme is dependant on one of those plugins and disabling it is causing grief. You'll need to swap themes to get your admin back up. Make sure you have a default wordpress theme in your folders, like twentynineteen.

From phpMyadmin, follow these instructions:

  1. Click on the wp_options table.
  2. Under the option_name column, locate the template entry. You may need to navigate beyond the first page of entries.
  3. Click Edit next to the template entry.
  4. In the option_value column, change the value to the name of your chosen theme. The new value must be the same as your theme's folder name.
  5. To save, click Go.
  6. Click Edit next to the stylesheet entry.
  7. In the option_value column, change the value to the name of the chosen theme. The new value must be the same as your theme's folder name(ex. twentynineteen).
  8. To save, click Go.

If you can then see your admin, then we can be sure your theme needs one of those disabled plugins. Flick them all back on, switch back to your original theme, and everything should work again. Then disable them one by one and find out which one is causing the break when removed.

Once you identify the plugin causing the problem, you can start troubleshooting.

Good luck!

| improve this answer | |
  • Thanks for the response! I swapped the theme via the method above but I still can't access my wp-admin. – Banitama May 23 at 8:14
  • Well nuts! At this point I would recommend restoring to an older version and starting over. Do you have a backup from before your changes? – Faye May 26 at 20:13
  • I have backups of articles in github, so in the end I reset my site and restore the content from the backup. – Banitama May 28 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.