0

On my site, I don't use the chop page or the cart page of WooCommerce as I directly send people to the checkout page. So, I tried to set the page visibility to "Private" but even after that anyone with the shop URL can visit the shop page and it is showing perfectly fine.

Private Shop Page

Whereas I created a normal test page and made it Private and when I am checking it from an incognito window it is giving 404. Exactly what I want. But this same thing is not working for WooCommerce default pages.

Does anyone know why? I have already tried all the troubleshooting steps but no result. I got no clue why the WooCommerce default pages are not respective the WordPress settings.

0

As per the answer here on the WooCommerce WordPress.org Support Forum:

The shop “page” isn’t actually a WordPress page. It’s an archive of all the products on the store. Because of that, it doesn’t behave like a typical WordPress page.

You could not assign a page to be the shop. Here’s how to do that:

select shop page

  • Go to WooCommerce > Settings > Products.
  • At the top in the drop-down for Shop page, clear the field.
  • Save your changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.