1

I added WooCommerce to my WordPress site and the Shop page is giving a 404. This seems weird because the page is listed in my "Pages" area like this "Shop - Shop Page", but when I try to preview it is not found. I tried uninstalling and reinstalling WooCommerce and also deleted the Shop page and recreated one using the WooCommerce tools. I also fiddled with the permalinks page (screenshot below), but no luck. --Also the Cart Page and other woocommerce pages are not working. Thanks for any guidance you can give on this.

enter image description here

1

What you've done here is changing slug for products. For example : http://localhost:8080/shop/product-category/sample-product as explained in WP, but not your Woocommerce home. Change the base to base default in permalinks settings. Then read after :)

If you want to change your "Shop Homepage" go to http://localhost:8080/wp-admin/admin.php?page=wc-settings&tab=products&section=display

That's the good way to do it !

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.