0

I have a wordpress site that we were versioning controlling. Any plugin/Wordpress base update would have to go through a merge request and then deployed. Well our deploy process is broken and I'm trying to grant access to Marketing to allow updates to the plugins without having it go through a developer. One problem: Wordpress is asking for connection login and for the life of me, I can't figure out how to disable it. Here's everything I tried:

1.) wp-config.php: Yes, I looked in there as per this form and a million others. We have only the basics in the config file.

2.) I tried setting permission 777 (for extreme measures) to the plugins folder which suggested and a few other sites. Still nothing. Our All In One WP Security plugin promptly changed the settings back.

3.) I tried looking through the WP Security plugin and I'm not seeing anything jump out at me as to it stopping any plugin updates.

Any other areas that might be causing this? We are using Wordpress 4.9.3.

0

So it was solved. I reached out to the WP.org forums and found a couple of guys who helped me through it. The owner needs to run as what user PHP runs as. In my case, it was www-data and that user needed to be owner throughout the project. Not just on the wp-content/plugins folder.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.