0

I am building a new server to replace my old server and wish to migrate my wordpress website to it. The old system is nearly identical except for age and because of its age, I am forced to make several upgrades.

Both servers sit in my basement where I access them directly through a terminal directly connected to the computer, so I do not (or should not) need to ftp anything. The new server is built on a new computer with an intel i7 CPU, 32GB RAM, Ubuntu 20.04 server OS with a MATE desktop environment and a LEMP stack (using the mariadb instead of mysql) and the newest version of wordpress. I have a test site set up for wordpress and everything was working perfectly until I attempted to install the updraftplus plugin.

I used updraftplus on my old system to backup my wordpress files and wanted to use it to restore those files on the new system. But in order to install it, I was required to set up an ftp server. (This was new to me as it never has been required before and I have never needed an ftp server for my previous web servers.)

Now, with the ftp server installed, wordpress forces me to enter my ftp credentials for all updates and plugin installations, and when I complete all the required actions I get error messages saying the installation failed (can't find wordpress content directory.)

I strongly suspect that it's the ftp server that can't find where to put the plugins. What I really want to do is to eliminate any wordpress dependency on ftp as it is totally unneeded for my system.

2
  • This is probably file permissions: WordPress needs FTP credentials because the user it (or the web server) is running as does not have permission to edit its own files. Can you verify that the file permissions are set correctly so that WordPress can update itself? (There might be a way to force using FTP for updates in configuration too but I guess you haven't done that.)
    – Rup
    Oct 16 '20 at 10:05
  • 1
    You are absolutely correct. The wordpress file permissions were incorrectly set. I reset them correctly and the problem is solved.
    – W R Knight
    Oct 16 '20 at 14:58
1

Problem solved. Incorrect wordpress file permissions. Reset all wordpress files with

sudo chown -R www-data:username wordpress
sudo chmod 755 -R wordpress

and the problem disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.