When a run a command such as wp plugin update I get the message: "Your server is running PHP version 5.4.13 but WordPress 5.2.2 requires at least 5.6.20"

I don't even have PHP 5.4 installed in my server.

When I run wp cli info I get the following:

PHP binary: /opt/plesk/php/7.2/bin/php
PHP version:    5.4.13
php.ini used:   /etc/php.ini

Any idea what could be causing this? I updated WP CLI to version 2.3 thinking maybe that would help but I get the same results.

Running CentOS 6 if that makes a difference.

  • What does /opt/plesk/php/7.2/bin/php --version return you? – leymannx Sep 4 '19 at 19:32
  • @leymannx It shows PHP 7.2.22 – Best Dev Tutorials Sep 4 '19 at 19:54
  • And just php --version? – leymannx Sep 4 '19 at 20:21
  • @leymannx php --version shows: PHP 7.0.27 – Best Dev Tutorials Sep 4 '19 at 20:27
  • Wow, by default even the CentOS 7 official software package repositories have PHP 5.4. Seems something got mixed up when you installed the other PHP versions. – leymannx Sep 4 '19 at 20:49

Edit your .bash_profile and modify the PATH with :

export PATH=/opt/plesk/php/7.2/bin:$PATH

then reload with :

source ~/.bash_profile

More info here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.