0

When I Google our company's name I get a much shorter title tag then when I search for a keyword that we rank for. The correct title tag shows when I look for our company through keywords but not when I search the company name (the same home page shows up but with different title tags).

I figured the title might be echoing the WordPress name but when I changed it in the WordPress settings, forced Google to index and waited a few days the title was still wrong.

I also checked the source code and the correct title tag is displayed in there.

I use Yoast plugin and have a title tag for our home page so that is not the issue. I also looked at header.php and the only two chunks of code that I found related to the title were:

<title><?php wp_title(''); ?></title>

and

<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" title="no title" charset="utf-8">

I should also add that my understanding of php/java etc is very limited.

Any help would be appreciated.

  • Google decides what title to use for the search result, and it will change depending on the user’s search query. It’s not something you can control. Google is not like a phone book where you get to choose what shows up. Google will display what it thinks is most useful to its users. For example, if the user searched for your company name, why would it show anything else? – Jacob Peattie Feb 9 at 1:32
  • But when I look up my company name it only shows the company name and when I look up another keyword it shows the full title tag. I looked at many other companies, and non of their title tag is affected like this. I'm thinking there is some kind of conflict in the code etc. – Ben G Feb 9 at 17:44
0

I think that your title is too long. That's why, Google has truncated it. However, if it's not the case, try resubmitting your sitemap.

Also, keep in mind that Google modifies the title according to what you're looking for.

  • The title is under the max limit. Also as I said I forced indexed it many times in the past few weeks and it has not changed. I'm thinking there is some kind of conflict in the code etc. – Ben G Feb 9 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.