1

On a wordpress theme I created I have a strange behavior:

On one of many page, I get the error err_connection_closed after about 20 minutes of loading and no content is displayed. But only when I am loggedin in the backend. I don't get the error when I logout.

Other Pages of the same Wordpress Website work fine...

I could reproduce it in chrome and firefox so far (have no IE).

I have no idea where to start debugging this one - and since the thing runs on a hosted server, I cannot see the access-log, which is a shame - I know (btw. I cannot reproduce this error on the tetstserver, which also has a ssl certificate).

I don't do any extra things of which I know, where I even check if I am loggedin or not.

Can that be an SSL issue? (It seems to occure since we installed a certificate, but not sure)

Can that be an JS issue or is it more likely to be an issue of the server. I don't get any other errors in the browser (console, or network)

enter image description here enter image description here

Has anybody had a similar problem?

  • Have you tried loading those pages directly to see what happens? Is there anything in your PHP error/warning log that might be related? Is /produktionen your WP root folder? – Tom J Nowell Jul 13 '18 at 17:32
  • Yes I checked that. Nothing. No it's a subpage – helle Jul 13 '18 at 21:20
  • What's on that subpage though? Have you done the standard disable all the plugins and themes and reactivate them one by one? WP_DEBUG? XDebug? Are you sure both production and your test server have the same versions of PHP etc? 23minutes is a very long time, double check your PHP time execution limit is a normal value most pages stop after 30s to 1 min as a top value – Tom J Nowell Jul 13 '18 at 21:25
  • 1
    I understand, and I wouldn't expect anybody to go through an entire codebase anyway, you're going to have to conduct a process of elimination, commenting parts of that template out until it starts working again to see what the culprit is, or the reverse, uncommenting until it breaks. If it's an SSL issue etc you should be able to tell by visiting the page and seeing what the chrome network tools say. Otherwise I'm afraid there really isn't much more anybody here can do without getting their hands on the real deal and spending an hour or two debugging – Tom J Nowell Jul 16 '18 at 9:52
  • 1
    Put simply the problem needs to be identified before it can be solved – Tom J Nowell Jul 16 '18 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.