0

While freshly installed, I cannot access the 'Add new plugins` page whatsoever. It just keep waiting & then redirect me to 404 page of the current theme.

I'm not sure what went wrong as the wordpress is freshly installed. Wordpress version is 4.9.6 & I'm using PHP7 for the host.

I tried solutions suggested for similar issues but cannot get it fixed. I also get this message when I'm at the Installed Plugins page

Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/tuva9001/public_html/wp-includes/update.php on line 347

0

I would rename the plugins page (via FTP or your hosting file manager) to disable all plugins and then try to access. You could also rename any non-'twenty' theme folders to disable those, so it would default to one of the 'twenty' themes.

Then look at other files in the site root, sorting by date (newest first) to see if there are some rouge files in there. Also look for same in the wp-* folders. And check your htaccess file.

  • I checked out every files based on the modified date but there were no files recently changed or went rouge. I just freshly install wordpress & it still happens. – Toan Lu Jun 12 '18 at 5:53
  • Was it a manual install of WP, or a 'wizard' thing from your hosting place? Latest version, I assume. Did you try renaming the plugins folder (some hosting places auto-installs install plugins as part of their package). Have you looked at the error log (in the root folder, and in the wp-admin folder) for hints? – Rick Hellewell Jun 12 '18 at 16:51
  • Hi @rick-hellewell I tried both the manual & wizard install provided by the cPanel. The version I installed is 4.9.6. I didn't try renaming the plugins folder yet. I think I will give it a try. One thing about the log file is that I turned on the configuration but it doesn't appear to have log anywhere. I chmod 775 for all folders – Toan Lu Jun 13 '18 at 2:05
  • Later yesterday, the hosting service gave me an answer on this matter as they're experiencing some bad network condition as the cable throughout global network are damaged, so the plugin page somehow can be accessed at randomly sometime. The connection to api.wordpress.org seems to be really bad. I will wait till they can give me better proof on this. Until then, I saw no solution seems to be working. – Toan Lu Jun 14 '18 at 2:16
  • Strange. Perhaps moving to a new hosting place ... – Rick Hellewell Jun 14 '18 at 18:40
0

Make sure you don't have the variable 'DISALLOW_FILE_EDIT' set to true somewhere in your installation. Shouldn't be with a fresh install. Most likely in wp-config.php

Try to add this to your wp-config.php define ('DISALLOW_FILE_EDIT', false );

Another thought, do you have the right rwx permissions and ownership? Changing file permissions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.