15

I'm running WordPress on a localhost WAMP server and whenever I go to "Plugins" or "Dashboard > Updates" or even to "Dashboard" nothing loads (no WordPress news, no updates, and I'm not able to search for plugins nor update them).

In the "Plugins" section, I see this when I try to search for something:

An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

Has anyone encountered this issue before? It happened overnight a few weeks ago for me. It was working for a long time and then one day it stopped. What I already done:

  • Searched Google and WordPress.org support forums. This issue is mentioned hundreds of times and there is no solution.
  • Checked php.ini, Apache's config, .htaccess, enabled potentially related PHP/Apache modules, checked if WAMP is set to "online" (my WAMP is accessible from other network computers now).
  • Allowed every permission for WAMP in "Allow a program through Windows Firewall".
  • Deactivated all plugins and themes other than the default one.
  • Checked [Settings > General] to see if URLs are valid and they are.
  • Resaved [Settings > Permalinks].
  • Installed another WordPress on this localhost and it works. So, why doesn't the first one?
  • Reinstall WordPress. – kaiser Oct 25 '13 at 10:31
  • 2
    @kaiser Yes, it will work and I did that. But why this happened? What happened? Should everybody facing the same issue and entering this question reinstall their WordPress (potentially live) websites when this happens? – Paul Oct 25 '13 at 11:18
  • 1
    I'd assume that the problem is incomplete or corrupted files. So yes, that would be my suggestion. – kaiser Oct 25 '13 at 11:25
  • 1
    I've been using WordPress 3.5 and then WordPres 3.6 for around 10 months on this localhost. It broke one or two weeks ago and today I wasn't able to update to WordPress 3.7. I updated /wp-includes/ and /wp-admin/ and other files except wp-config.php and /wp-content/. When I entered localhost/wp-admin it asked me to update the database and updating to WordPress 3.7 worked but the issue remained. So, reuploading files and updating WordPress isn't a solution. This is perhaps something wrong with the database. Reinstalling entire WordPress and cleaning database helps. – Paul Oct 25 '13 at 14:19

10 Answers 10

5

In my case, it was simply the SITE URL left blank in Settings -> General. I filled it with my site URL, and everything started working again.

I found out by enabling WP_DEBUG in wp-config.php, and I got this error: "Notice: Undefined index: host"

3

For me, the issue was that my localhost software (MAMP, on macOS) was not able to make a secure connection. After enabling WP_DEBUG and checking the log file, I saw the following error (emphasis added by me):

PHP Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server's configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in wp-includes/update.php

After a bit of research, I found one site saying that my PHP cURL extension might be disabled. I created a phpinfo() page to check; it was already enabled.

Then I found another site saying that MAMP comes with a libcurl library which is missing a ca-cert bundle. I'll copy the page content here, just in case this page lasts longer :)

If you're using MAMP and doing something with cURL, chances are that you'll run into following error:

CURL error (60): SSL certificate problem, verify that the CA cert is OK. Details:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Don't worry: MAMP is bundled with curl library that seems to be missing a ca-cert bundle, which we'll solve by simply recompiling libcurl MAMP is using

So, let's do the following:

  1. Run /Applications/MAMP/Library/bin/curl-config --version to see which version you've got

  2. Go to http://curl.haxx.se/download/ and download the right version

  3. Configure it with ./configure --prefix=/Applications/MAMP/Library/

  4. make && make install

If everything went fine, just restart MAMP and the error should be gone

Copied from http://dev.soup.io/post/56438473/If-youre-using-MAMP-and-doing-something

  • I noticed once the configuration step was complete that SSL Support is set to no, and SSH Support is set to no. Will this also be causing issues? – Adam Patterson Aug 5 '18 at 16:35
0

Well Even had Got a similar issue, It way resolved by following steps.
1) Login to "Cpanel" of Your Hosting
2) Goto "Health Checks and Monitoring"
3) Click "Port 80"
4) Check if its Blocked ,
a) YES>>Delete files which may be listed there.
b) NO >> Contact your Hosting Support.
5) if 4a>>Click unblock the port , It might take couple of min/hrs to get unblocked.

  • He's on localhost and he mentions this in his first line. – trainoasis Apr 10 '18 at 10:39
0

Encountered the same problem. Dashboard was loading fine, just the Themes and plugins sections were really slow.

Found out that it was just a DNS problem after checking with nslookup, which gave me this :

Server:     127.0.0.53
Address:    127.0.0.53#53

instead of my actual ip adress.

Solved it by doing this :

sudo rm -f /etc/resolv.conf
sudo ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf
reboot 
-1

After spending more time is this I have solved this by looking at

wp-config.php

Make sure this flag is false, if it's true update couldn't be happen

define('WP_HTTP_BLOCK_EXTERNAL', false);
  • I have this set to false, the issue is still there. – trainoasis Apr 10 '18 at 10:38
-2

Try to ping wordpress.org, put dns entry in /etc/resolv.conf

-2

Edit wp_config.php and add the following piece of code to the buttom of the file:

define('FS_METHOD', 'direct');

That should allow plugins and themes installation directly from the online repository.

-2

Go to This page download the plugin zip file and install it then activate it.

Go to your WordPress Dashboard, click WPCF Editor, Open Tab Proxy.

Set your HTTP Proxy.

At least it works on mine.

-2

Just define your site URL in the wp_config file, example:

define( 'WP_SITEURL', 'http://localhost/your_site' );
define( 'WP_HOME', 'http://localhost/your_site' );
-2

This is how my issue fixed.

Step1: Go to Cpanel
Step2: Click on "File Manager"
Step3: Open "Wp-config.php" in edit mode.
Step4: Paste this line define('WP_HTTP_BLOCK_EXTERNAL', false); at the end. Step5:Save the file

Now check your http://yourdomain.com/wp-admin/ Dashboard - i Guess it will be fixed.

  • He's on localhost and he mentions this in his first line. Also, this doesn't fix the issue :) – trainoasis Apr 10 '18 at 10:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.