0

Every post and page is not found. I checked .htaccess, generated a new one, debugged (disabling plugins), checked the static page and the blog page, also nothig. The last thing I did was check if everything was ok in the database, and the posts and links are there and if I use the database url is the same 404 not found.

1

Did you try to re-save Permalinks?

Navigate to: WordPress Dashboard > Settings > Permalinks: Click "Save Changes" and then click on the link of the page that should work from the "Edit Page" of that page.

Also review Permalinks settings if they are correct.

If it still doesn't work, you can try to debug the generated permalinks with Debug This plugin.

After activating this plugin go to: Admin Bar > Debug This > Query > Rewrites and check if the rewrite rules are correct and exist for the url that should work.

| improve this answer | |
  • Thanks for the answer, I tried all that and nothing happen :/ I also rechecked the static and the blog links, and all it seems ok – Carlos Aponte Jun 19 '17 at 19:40
  • Do you have any cache plugin? And when you say you disabled plugins, did you disable all of them and still did not work? – dbeja Jun 20 '17 at 8:49
  • I purged all the caches, and yes I disabled all the plugins, also I tried disabling one by one, but still nothing :/ Do yo have any other idea? This is weird it the first time it happens. – Carlos Aponte Jun 20 '17 at 13:11
  • Ok, what if you change your permalinks to Plain (Settings > Permalinks > Plain option). The new urls of the pages still don't work? If they do, could it be that hosting disabled mod_rewrite on apache? – dbeja Jun 20 '17 at 13:26
  • Indeed, mod_rewrite was disabled, 1 minute and 1 command later, done, hahaha. Thank you! :D – Carlos Aponte Jun 20 '17 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.