4

Help! All of a sudden my Wordpress admin has started showing a 'Error 404 Page Not Found' message whenever I try to update an existing post or page on my site.

Creating new posts and pages works fine.

This happened suddenly last night when I was updating a series of posts and it suddenly started showing this message.

So far I have tried:

  1. Settings > Permalinks Save button
  2. Disabling all plugins
  3. Updating all plugins
  4. Changing theme
  5. Deleting all WP content apart from wp-config.php and wp-content folder, and uploading fresh Wordpress install
  6. Updating Wordpress

I'm not sure what else to try?

  • Since you've already tried all those steps, I'm inclined to think it's a server/hosting issue. It could be some kind of problem with either site or object caching. – socki03 Oct 13 '16 at 18:49
  • apparantly an OP @toscho, didn't think i was helping so deleted my answer. were there errors in your error_log? – rudtek Oct 13 '16 at 19:15
  • I'm downloading error log now - it's 5gb so will report back soon! Thanks – Matt Falcus Oct 13 '16 at 20:00
  • You have to contact your hosting provider before doing any change, Because if you are using shared host you will not find any ModSecurity section, So contact your hosting prodiver they will fix the problem. – Bulbul Bigboss Nov 5 '17 at 9:07
0

Updating Permalink changes update your permalinks settings and flush rewrite rules. In most cases this fixes the WordPress posts 404 error. BTW, you already tried this and I hpe your .htaccess should be writable. Have you checked it?

If not then you can change .htaccess file permission temporary writable by changing the permissions to 666 and make sure after after 'Save Changes' action turn back .htaccess permission.

4

Disable ModSecurity in cPanel

Updating and previewing pages/posts were kicking up 404s suddenly on all my websites - but not for all pages and posts (always just the ones I wanted to edit).

I went through all of the steps mentioned above including installing back-ups with no success. After finding downloaded versions were working on my local xampp the logical conclusion was something had changed on my hosting package.

Solution that worked for me: cPanel/Security/ModSecurity - Disable

If concerned that you are reducing security then just turn it back on again after updating pages/posts.

1

I tried many techniques. Upgrade the memory of upload downloading of file, made changes in ht access file. Clean up the project and installed new wordpress and created new website and much more. All fail.. This one work and I am free of problem.

Thanks..

Copied: Disable ModSecurity in cPanel

Updating and previewing pages/posts were kicking up 404s suddenly on all my websites - but not for all pages and posts (always just the ones I wanted to edit).

I went through all of the steps mentioned above including installing back-ups with no success. After finding downloaded versions were working on my local xampp the logical conclusion was something had changed on my hosting package.

Solution that worked for me: cPanel/Security/ModSecurity - Disable

If concerned that you are reducing security then just turn it back on again after updating pages/posts.

Not the answer you're looking for? Browse other questions tagged or ask your own question.