0

The later blog pages give a 404 error.

For example page 7 works fine: http://www.ismyhomesafe.ca/blog/page/7/
Page 8 gives you a 404 error: http://www.ismyhomesafe.ca/blog/page/8/

Any suggestions would be appreciated!

1 Answer 1

1

First, try rebuilding your permalinks. Go to Settings >> Permalinks and click Save, which will rebuild them. If that doesn't work, go into your Settings >> Reading >> Blog pages show at most setting and try increasing or decreasing that and see how that changes things.

Some themes have a setting that lets you adjust how many posts per page display in the loop that can conflict with the main WordPress setting, so if you can edit your theme options, try ensuring there isn't a setting in there you need to adjust.

One thing I'd also try if none of this works is disabling all of your plugins temporarily and reverting to the default WordPress theme just to isolate the cause of the issue. If it works, then switch back to your current theme. If it still works, you'll know it's plugin-related. If not, you'll know it's theme-related.

3
  • Hi, thanks for the suggestions! Changing the posts per page seemed to do it!
    – Krystle
    Mar 15, 2017 at 13:36
  • @Krystle excellent! If you don't mind marking my answer as the correct answer, that would be great, thanks! Mar 15, 2017 at 13:41
  • Yes of course! (Sorry, I'm new to posting here.)
    – Krystle
    Mar 16, 2017 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.