0

We noticed a weird issue on our WP 4.9.10 blog pages when going to 1st page. Right now we can go to 2nd or 3rd page by clicking the page numbers but saw that it gives 301 code when going to 1st page but gets 200 response code for 3rd or 4th, and so on.

Clicking the Previous button on the blog pagination at the bottom takes you to a page with hosted server name.

This sometimes happens when clicking 1, 2, 3, when you are on page 4 (and so forth for other pages).

https://www.oursite.com/blog/category/news/page/1/

At the end we get site can't be reached because WP blog is set up inside DMZ with reverse proxy set up.

https://hostedservername.com/blog/category/news/

We have not customized any PhP code other than making few changes to admin panel settings and http conf changes to work with reverse proxy and https only.

0

please go to setting > permalinks and click on the save button if you are using nginx reverse proxy check this page: https://codex.wordpress.org/Nginx

  • We are using Apache but I will check above post and see if it helps our issue. – cnu Apr 19 at 1:54
  • Looked at it and it's not applicable. – cnu Apr 24 at 13:56
0

Followed fix mentioned here to resolve pagination issue. Updated functions.php file to include add_filters function as mentioned there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.