0

I have obtained an SSL certificate for my main website and not for the sub domain name (I can't afford a separate one at the moment) which pointed to my blog. The links to the blog come up as insecure on the new https page.

Both the site and the sub domain are hosted on the same server. I have successfully moved the Wordpress directory folder into the same directory as the main website (i.e. the Wordpress folder is now a sub directory of the main https site)

The old http:// subdomain link is redirected to it and everything still works fine via: http:// blog. mywebsite .co.uk.

My main website is now https: //mywebsite .co.uk

I want to create https:// mywebsite.co.uk/ blog instead of the sub domain and show a preview of the latest blog post on my home page.

I have linked to the Wordpress directory from the main site. The link works, but none of the styling appears when I follow that link. Can anyone help me with this, please?

I suspect I might have to start a new blog and unpack wordpress into a new subdirectory, but I would rather keep the old blog working.

Is guess there must be a way to import everything from an old blog to a new one?

I have room on my home page for the last three posts. I have been updating these manually. I guess there must be some means by which I can access these directly. Please would someone enlighten me!

Many, Many thanks,

Iv

(p.s. I have split the links so I can post this.)

  • Hi, did you make the subdomain yourself? You can delete your subdomain and simply move your WordPress installation files into /blog/ directory of your website. You might want to update your .htaccess and wp-config.php file too. I will post an answer if you provide technical information. – Jack Johansson Feb 13 '17 at 20:13
  • Hi Jack, and thanks. The subdmoain name was pointed to the blog directory on the server. I have moved that folder and all of its contents into directory of the webpage and have redirected the subdomain name to point at that new location. I have also pointed links from the website to the blog directory. If I access my site using http:// I follow a link to the blog and it loads okay. If I access my site using https:// I hollow the link but none of the Styling works. What technical info do you need? – user113245 Feb 13 '17 at 21:01
  • Information such as the content of your .htaccess (at least the part that is related to mod_rewrite), the output link to your style when you use https:// in the header, and the values in the Site Url in the settings of your WordPress. A link to your blog would be appreciated for investigation, if possible. – Jack Johansson Feb 13 '17 at 21:09
  • By the way you can give this and this plugin a go. It might do the trick without going through all the coding. – Jack Johansson Feb 13 '17 at 21:10
0

Thanks for your help, Jack, it was really useful.

What I ended up doing was using the export and import function in the control panel. I returned the original blog to the main server directory. I then created a new installation of Wordpress inside my website's directory. It was just then a case of exporting the data from http://blog.mywebsite.co.uk/ subdomain and importing it into the new directory https://mywebsite.co.uk/blog. I did this from the Wordpress Dashboard > Tools menu.

Everything transferred a treat.

Thanks once again for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.