0

I was trying to set custom permalink but I am getting an error 404. Below are the settings I have tried:

  1. I have gone through Settings > Permalinks > Custom and added /%category%/%postname%/. It does not work.

  2. Verified the contents of my .htacces file:

**# BEGIN WordPress**
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
**# END WordPress**
  1. I have used a plugin.

However, I am still getting a 404 error page for the category that I have created. Can any one please help me?

  • can you share actual website url and example link? try to click "save permalink" buttononce again,see if it works. – T.Todua Jan 24 '17 at 6:56
  • Please deactivate the plugin used if It works well – Pratik bhatt Jan 24 '17 at 8:26
0

I am not sure about the plugin you are using but the above permalink structure worked for me. This is the code I used.

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

Please note I had to enable mod_rewrite module for this to work. After enabling, make sure you restart apache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.