Hi there I want to disable automatic formatting of table/td/tr widths and heights in WordPress TinyMCE.

I create the table, literally type the data in (not copying it from word or anything like that) and it adds in width and heights to my table cells. Then I copy the code into a text editor and remove the widths and heights, then paste it back in and it adds the widths and heights again.

Its giving me a headache. The table is responsive using bootstrap classes so no need for widths and heights.

If I want widths and heights I will manually put them there.

How to disable this??

  • tinyMCE is not exhibiting this behavior for me. Are you using a plugin such as tinyMCE Advanced or some kind of table plugin? The only way I'm able to get tinyMCE to add width and height attributes to the table markup is if I enter the HTML in the text editor, then switch to the Visual editor and drag the handles on the table to resize it. – Dave Romsey Sep 20 '16 at 2:51
  • Yes I am using tinyMCE Advanced - does this exhibit this behaviour? Thx – RRowan Sep 20 '16 at 3:15
  • Sorry, I don't use it. I just had a hunch that you were :) Questions on third party plugins and themes are off topic here on WPSE, but you can try you luck over on the plugin's support forums: wordpress.org/support/plugin/tinymce-advanced – Dave Romsey Sep 20 '16 at 3:18
  • 1
    I disabled this plugin as a solution – RRowan Apr 13 at 1:42

The general recommendation seems to be to downgrade TinyMCE Advanced to version 4.6.7. I just did this myself and it solved the problem.

I needed to clean up the HTML of the affected tables by hand though.

There's a topic on the plugin's support page with some other suggestions.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.