1

Everytime I copy something, Wordpress will format the content like it was in that text. For example if I copy a link from Wikipedia, Wordpress will format that word to be bold, blue and with underline. This is tilting me so hard.

I have tried the following from Disable TinyMCE autoformatting and I didn't noticed anything

remove_filter( 'the_content', 'wpautop' );
remove_filter( 'the_excerpt', 'wpautop' );

I have also tried this plugin, it doesn't work and it generates errors https://wordpress.org/support/view/plugin-reviews/ps-disable-auto-formatting

How to disable formating so that the copied link words will be only regular words? There is a button "remove formatting" but it doesn't do a thing in this case.

1
  • 2
    CTRL + Shift + V will paste without any kind of formatting, just like in a Word Document.
    – Howdy_McGee
    Jan 20, 2016 at 17:15

1 Answer 1

2

Please use this code in your functions.php

function tinymce_paste_as_text( $init ) {
      $init['paste_as_text'] = true;
      return $init;
    }

    add_filter('tiny_mce_before_init', 'tinymce_paste_as_text');

For details please follow link :

This will paste copied text in plain format

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.