0

I use default page break tags in my posts and unfortunately RSS feeds do not show the full content without the page breaks. I am currently using WordPress 4.5.3.

I have "For each article in a feed, show" settings set to "Full text".

What can be the problem and if this is not a problem, what's the best way to fix this in my case?

1

If you mean how to ignore <!--nextpage--> in the feed content, then we can adjust this approach for feeds:

/**
 * Disable content pagination for feeds
 */
add_filter( 'content_pagination', function( $pages )
{
    if ( is_feed() )
        $pages = [ join( '', (array) $pages ) ];

    return $pages;
} );

where $pages is an array that contains the content parts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.