0

hello i have this site and in the footer section there is the recent posts widget with the grey colored text. I wish to change it to white, i tried adding some custom css code in the theme child with no success.

5
  • Hi DLMike, welcome to WPSE, this is purely related to CSS not specific to WordPress and considered off-topic. Also you didn't post any on what have you tried.
    – bravokeyl
    May 14, 2016 at 10:06
  • You haven't activated child theme.
    – bravokeyl
    May 14, 2016 at 10:09
  • hey sorry the theme offers me an option of custom css code in theme settings menu. this is the code i have tried so far: .widget_posts_wrap a {color: #000 !important;} #widget_posts_wrap .latest-posts .col-md-12 h3 a{ color:#ffffff;} #widget_posts_wrap a {color:white;}
    – DLMike
    May 14, 2016 at 10:11
  • Hi DLMike, I think we need some more information. Are you sure your child theme is activated and that the code was added to the theme options of the child theme? Otherwise it could be an issue with the CSS but we would need a link to determine. I agree this may be off topic as it may not be WordPress specific.
    – mantis
    May 14, 2016 at 10:31
  • Yes I am sure. Because i have added some other older code in the theme settings of the custom css and they worked perfectly for instance #javo-navibar ul.navbar-left>li>.dropdown-menu>li>a{color:black !important;}
    – DLMike
    May 14, 2016 at 10:37

1 Answer 1

0

This CSS will make your grey text in some else you want:

.widget_posts_wrap .latest-posts .col-md-12 a span {color:#your-hex-code !Important;}

This is for subtitles in this widget where you have latest post.

And this is for titles:

.widget_posts_wrap .latest-posts .col-md-12 h3 a {color: #your-hex-code !important;}

Also just note to change #your-hex-code part with actual hex code.

I hope this helps.

6
  • I have added this in the child-theme.css and in the theme settings with no change #widget_posts_wrap .latest-posts .col-md-12 a span {color: #FFFFFF !important;} #widget_posts_wrap .latest-posts .col-md-12 h3 a {color: #FFFFFF !important;} .widget_posts_wrap .latest-posts .col-md-12 a span {color: #FFFFFF !important;} .widget_posts_wrap .latest-posts .col-md-12 h3 a {color: #FFFFFF !important;}
    – DLMike
    May 14, 2016 at 11:26
  • do you use cache plugin? if you are using please clear cache as you might see older version of your site.
    – Usce
    May 14, 2016 at 12:20
  • nope already did that in the first 2 minutes over and over again after i added your code
    – DLMike
    May 14, 2016 at 13:13
  • Maybe you don't have right configuration in your theme set that it load CSS from right source, or you don't have activated child theme or something, please check that stuff, because this CSS is right
    – Usce
    May 14, 2016 at 15:05
  • figured it out it seems the problem was with "#" or "." at the beginning of the css code removed that and worked fine. Thank you alot for your patience and help
    – DLMike
    May 14, 2016 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.